PDA

View Full Version : Why do my renders turn out so bad?


Corrupt3d
02-26-2005, 06:45 AM
Why are they so grainy...and though this is probably because of my noobiness, why are they so "undramatic"?
https://home.comcast.net/~ThingOne/asdf.jpg

https://home.comcast.net/~ThingOne/fdsaa.jpg

https://home.comcast.net/~ThingOne/fdsa.jpg

Corrupt3d
02-26-2005, 06:47 AM
btw, in terms of lighting i am using a simple ambient light. I'm using Maya 4.5 unlimited, and it's all poly's. The shaders I got from highend3d

T-R
02-26-2005, 07:11 AM
i am using a simple ambient light
Well thats your first problem. Try using a spot light or a a point light. Also turn on shadows!! check out this LINK (http://www.learning-maya.com/rendering.php) and look for 3 point lighting.

dudders
02-26-2005, 08:56 AM
why are they so "undramatic"

...because what could be more dramatic than a chair floating in space :scream:

Sorry just kidding, yes as T_R said and never use ambient light if you can help it as it washes the whole scene out, and even if it was dramatic in terms of subject, the ambient light would flatten it all the way to dull land.

If you delete all the lights in your scene, hit 7 so the viewport shows you lighting, and insert one light like a point or a spot and then another and go from there, building the lighting up in degrees. Remember you dont want lights to flood and washout your objects, you want them to define them in space.

If you can, get a book about stage and film lighting design, or look at lighting in films or plays. This would help you a lot.

kevinstiles
02-26-2005, 09:35 PM
Check you render globals. set the globals to production quality. you can find that under the Maya software tab -> quality (drop down menu,) select production quality. The other thing you want to do is turn on shadows. After you greate a light select it and press control + a this will display that light's attributes. Open the shadows attributes and turn on depth map shadows, change the Dmap resolution to 1024 at least, trun the Dmap Filter size to somewhere between 2 and 4 (3 is a good number.) You may also find that turning up the Dmap bias is helpful. You said you were a newbee so I gave you the basics I hope I didn't insult you.

Also working on composition. An empty chair sitting in the middle of the composition is not dramatic. Try putting the camera at the level of an ant sitting in front of the chair, or something like that. And get a newer version of Maya. Good nluck!

Corrupt3d
02-27-2005, 04:37 AM
Check you render globals. set the globals to production quality. you can find that under the Maya software tab -> quality (drop down menu,) select production quality. The other thing you want to do is turn on shadows. After you greate a light select it and press control + a this will display that light's attributes. Open the shadows attributes and turn on depth map shadows, change the Dmap resolution to 1024 at least, trun the Dmap Filter size to somewhere between 2 and 4 (3 is a good number.) You may also find that turning up the Dmap bias is helpful. You said you were a newbee so I gave you the basics I hope I didn't insult you.

Also working on composition. An empty chair sitting in the middle of the composition is not dramatic. Try putting the camera at the level of an ant sitting in front of the chair, or something like that. And get a newer version of Maya. Good nluck!

no insults here!

thank you to all for the help, i'll try and re-render this again, and hopefully have a better looking picture.

for the record(s), the chair is floating, its actually on the ground, but the render and camera angle makes it look like its floating:)

regardless though, im gonna get the newest version of maya (if 7.0 is out by that time) this june, once school is over and i can devote more time to fun stuff

Corrupt3d
02-27-2005, 06:47 AM
http://home.comcast.net/~thingone/chair.jpg

new render with three point lighting. I need to work on the legs some more in terms of lighting...natural color should be silver and not black...anyone know where I can get some good steel colored shaders?

Jackdeth
02-27-2005, 07:42 AM
Steel/chrome is the color of the enviroment around it.

dudders
02-28-2005, 01:26 PM
One more piece of advice, try not to have more than one shadow like that, as it just looks messy. One tip is to have a point light giving a shadow and then duplicate it in exactly the same place (but take the shadow off) and set the light to -1. You will now have a light that gives off shadow but no light. You can then tweak the shadows to help the composition.

Image looks better

Undead Fred
02-28-2005, 02:11 PM
Also, I'd recommend messing with your penumbra angle and dropoff under your spotlight attributes. You can also use light linking under your relationship editors to break the link between your fill and rim lights with the floor... that way, you can get the effect of just one spotlight lighting the chair and the other lights will appear more natural.

Corrupt3d
02-28-2005, 06:47 PM
http://home.comcast.net/~thingone/chair3.jpg

how about this one? I added some feet and another light. The fourth light is directly to the right of the camera, and is linked only to the feet. Also, I took the advice to duplicate the main light and light link it to only the floor...

I need to work on the ambient lighting some...

BillSpradlin
02-28-2005, 08:05 PM
Add a penumbra to your light, some drop off would be good as well, usaully some linear decay will add to it as well. If you are using raytraced shadows you can turn up the light radius and increase the shadow rays to get soft shadows instead of those very harsh cg shadows you have going on now.

Undead Fred
02-28-2005, 08:06 PM
Ambient's not bad... your shadow areas aren't unnaturally dark or anything. I'm not sure if I totally like the light only being on the feet pegs, but I'd say the only thing I'd really like to see is taking the penumbra angle up (doesn't have to be much) and the dropoff turned up a little (1 would be good) so your spotlight doesn't have razor-sharp edges. If your shadows are pixelated, simply turn up your depth map filter on your shadows until you can't see any more pixelation.

Corrupt3d
03-01-2005, 12:54 AM
I worked with the dropoff and penumbra a little, the edge of the light is not as sharp anymore, i'll try and get new pics up cause it looks alot better...

also, i'm gonna work with the ray trace a little...i too dont like the sharp fake-like shadows...

dudders
03-01-2005, 12:03 PM
oh yeah :thumbsup: Looks a whole lot better than it did.

try this link also to help with the shadow.

LINK (http://smorigin.scm.cityu.edu.hk/intranet/easn/docs/HowTos/attenuatedDmapShadow/index.html)

It's advanced, but I hope you get on ok with it.

Somhairle
03-02-2005, 04:52 AM
Hey corrupt3d,

thats starting to look good. The only other thing I noticed is the image format quality.

Put this line into the "C:\Documents and Settings\USER\My Documents\maya\X.x\Maya.env" file. It will make a BIG difference when rendering to the JPEG format.

#

AW_JPEG_Q_FACTOR = 100

#

- Somhairle

Corrupt3d
03-03-2005, 04:06 AM
Hey corrupt3d,

thats starting to look good. The only other thing I noticed is the image format quality.

Put this line into the "C:\Documents and Settings\USER\My Documents\maya\X.x\Maya.env" file. It will make a BIG difference when rendering to the JPEG format.

#

AW_JPEG_Q_FACTOR = 100

#

- Somhairle


sweet! I'll add it, but does it matter where in the file it goes?

And what does it do?

dudders
03-04-2005, 12:26 PM
I dont think it matters where it goes. It turns your jpeg quality up to 100%

DrOnion
07-15-2005, 07:04 PM
Wow. Never knew that jpeg trick.
Not that I render to jpegs anymore but cool anyhow.

CGTalk Moderation
07-15-2005, 07:04 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.