PDA

View Full Version : Transparency problem


shserge
02-15-2005, 01:23 AM
Hello, guys!
I have a scene inside of the sphere. The sphere has no primary visibility and has inverted normals. In the scene i have the belt (actually it's just a plane, double-sided. plane has no thickness, it's not the box). At this belt i applied transparency map, map is somewhere black, somewhere white. So some parts of belt need to be invisible. But after rendering by mental ray this (invisible) parts looks painted white. I don't know why. Please, help.

BillSpradlin
02-15-2005, 01:28 AM
Set the default color of the texture file to black and make sure your shadow attenunation setting under the ray trace tab in the attribute editor of your base shader applied to the belt is set to 0. Also make sure the texture file's outAlpha is driving the base shaders transparency.

shserge
02-15-2005, 02:54 AM
Thanks fo help. Anyway it did not work.
I set the default color to black and shadow atttenuation to 0.
The transparency map is jpg file. I connected it's alpha to shader transparency R,G,B. But invisible parts still looks white. The interesting thing is that they look white only if after them there are no other objects except sphere.
I also tried to check Alpha Is luminance, but the result is still the same.
I tried to connect files outColor to Transparency, but also have the same result.

BillSpradlin
02-15-2005, 03:06 AM
Try using a file format that supports alpha, such as .iff or tga, jpg does not.

shserge
02-15-2005, 03:21 AM
I also tried to do this.
I did tiff with alpha in photoshop, but don't work. Currently i decided to remove sphere from scene, because i don't use fg and gi there.

Jozvex
02-15-2005, 04:24 AM
Try setting your 'Shadow Method' (in the shadow section of the Render Globals) to 'Simple' rather than the default 'Segments'. That fixed a whole bunch of transparency problems for me the other day!

misterdi
02-15-2005, 06:00 AM
Maybe when you are looking at the invisible part, the rays is not primary rays anymore. It becomes refracted rays, and it will show the sphere because it only disable primary rays on the sphere by turning off primary visibility.

I remember there is a thread in this forum and its involving another node something called like "raytype"?.

shserge
02-15-2005, 01:41 PM
Thanks for help, guys!
I tried all things you answered, bur still it does not work. In the scene there is no refraction and reflection.
It work right, if after belt is some other objects, but wrong if only sphere. When i removing the sphere, then everywhere is right.

CGTalk Moderation
02-15-2006, 02:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.