PDA

View Full Version : Foot Rotates when i move the the hips?


tedledz
01-18-2005, 03:46 AM
Hey everyone, ive got a problem, when i move my riggs hips down, then to the left or right one of the feet rotate on the spot. :banghead: Ive tried everything i can think of. I know this explination isnt very good, i have a pic to show what i mean but i dont know how to get it on here, also i dont have a website to put it on. :cry:

:sad: Anyone, please help.....

Coaster
01-18-2005, 08:56 PM
Sounds pretty strange only one of them moving, are your legs IK?

To post images goto http://www.imageshack.us/ and host it there.

tedledz
01-18-2005, 10:00 PM
Hey thanks Coaster, for the place i can host my images :thumbsup:

So here is my image:http://img50.exs.cx/img50/8978/rigfootproblemtwisting7ml.jpg OK when i move number 1 (Hip) down then to the left or 2 (The left foot only) rotates on the spot back and forth :shrug: . Iv been exploring it and iv found it only starts doing it once i pole vector the knee CTRL to the ankle IK. So any suggestions..

tedledz
01-19-2005, 12:53 AM
:bounce: i fixed it i fixed it, yay. Thanks all for you help. :buttrock:

Coaster
01-19-2005, 01:04 AM
Maybe your problem is the "pole vector the knee CTRL to the ankle IK"
I think you mean that you are constraining the pole vector to the knee?
First try grouping the IK handle for the leg to itself, this can freeze the
Or, you could try this instead,

http://img103.exs.cx/img103/8013/ikwoe5ty.jpg
RotatePlain IK the hip to the anke, (blue line) which you've already done, don't bother about the pole vector to the knee thing, instead use the twist attribute of the IK handle to do the same job, If the knee goes mad when the foot is raised high, then use the show manipulator tool to display the pole vector, it should be a facing forward arrow head (yellow triangle) move the pole vector so the arrow points to the side (white triangle)youcan point snap this to the leg bone and then move it to the side for a perfect 90 degrees, this will rotate the whole leg 90 degrees too, so use the twist attribute to rotate it back, the leg should behave better, and you roll the leg using the twist with 90 degrees as the default (front facing) position.

If I've completely misunderstood your problem then maybe post a shot of your hypergraph, as I'm not sure where your using IK.

hope this helps.

tedledz
01-19-2005, 04:53 AM
:shrug: You know i worked around it works fine now, but its no from when i do the pole vector it happens before, and its all ways the second leg i creat :shrug: I use mirror joint and have tried different settings in there but it didnt affect it. What u explain sounds abit complex But Hey Thanks for the great effort in helping me. :thumbsup:

CGTalk Moderation
01-20-2006, 12:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.