PDA

View Full Version : How to make hdri map, which won't be render?


Paweł Gajlewicz
09-02-2002, 01:11 PM
I want to render image with hdri map(finalrender)
How to make hdri map, which won't be render?
I go to render > enviromment >choose map > hdri map, then I go to material editor and I choose my hdri map, but when I render it, I have got this hdri map as background, but I want to render it without this hdri.

Sorry, for my poor language...

Fex
09-02-2002, 03:10 PM
don't know how to this in Max but your background doesn't
creates an alpha so maybe composite someother background
or color ..

hope that helps:beer:

Chris
09-02-2002, 09:25 PM
or you can just render with show samples on, & ratracing off (to speed things up). Once you have generated your GI solution, change your environment map to whatever you want & re-render with 'reuse solution' checked. It will render as if you had the HDRI there, but you will see the new background you put in!

or

If you have the latest patch, available from the Cebas family site thingie, you can just put the HDRI image into the skylight slot in GI Globals. That will generate the light, but wont show up in the render...

Paweł Gajlewicz
09-03-2002, 12:19 PM
oki, but there is one little problem... how to re-render image???

Chris
09-03-2002, 09:36 PM
just click 'render' :) because you have 're-use solution' checked - it will not re-calculate the GI solution, so your lighting will not change

Paweł Gajlewicz
09-04-2002, 10:42 AM
Chris, have you ever done it, couse it doesn't work for me:(
Fr does not count gi again, but reflection on my object are new(ennviroment is white and reflections are white, and I want to have old reflections from hdri map:)

Chris
09-04-2002, 09:12 PM
arg. Thats a little bit more difficult. The easiest way would be to create a sphere around your scene (invert the normals to make it face inward) & apply the HDRI map to that. in the spheres properties, uncheck 'visible to camera'. Now your sphere with the HDRI should reflect in your object, but should be invisible, so you can see through to the environment in the background. Hopefully you have saved that GI solution, so you can just re-use that for the indirect lighting. :)

Paweł Gajlewicz
09-04-2002, 09:53 PM
Unfortunatly, I have to say again: NOPE:(
In this way, reflections from hdri map are much ugly, and white ennviroment still affect my objects(have white reflections, non hdri reflections)...

Chris
09-04-2002, 10:53 PM
Wierd, I'm sure I've had that work for me before... :shrug: - you could try unchecking 'consider background' in the raytracing parameters to get rid of the white reflection. You could also try applying the HDRI map as a reflection map on the object itself. Is it possible to post a small screenshot showing what you mean by the HDRI reflections being 'ugly' ?

Paweł Gajlewicz
09-05-2002, 10:20 PM
My fault - bad parameters of hdri map, now reflections on objects are good, but I did it in other way.
Just like you said i created sphere and gave it a white color(not hdri map) and uncheck 'visible to reflactions/reflections'> Then I dawnload hdri map in ennviroment and everythink is ok:)
Thx for help:)

CGTalk Moderation
01-13-2006, 04:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.