PDA

View Full Version : 4.2 and Belly, please help :)


Pilchard
12-15-2004, 05:18 PM
Howdy folks!

I am currently creating a fat guy character, and throughout the modeling I am testing him with the biped rig. He will have a belly, so I have been using the belly option, which has been working fine.

I finally got around to updating to 4.2 (from 4.0), and have continued. However, the belly in any rigs I create in 4.2 is not dynamic, and just stays put!
The rigs I made in 4.0 open up fine in 4.2 and work as normal.

Any help guys please! I am the only XSI user at my college so our Maya dude cannie help!
I checked, and the spring effect is in place on the effector etc. Also tried a re-install and that hasn't helped.

Many Thanks :)

Ablefish
12-15-2004, 09:48 PM
I think there are some new options with the spring operator, including the use of a cache and initial states. Maybe that's where the problem is.

Pilchard
12-15-2004, 10:18 PM
Thanks 4 the reply Ablefish!

Could be as you say, there seems to be more to play with, but can't see anything to activate the effect.

Here are some screenies. The first is a biped rig created in 4.0, but open in 4.2. The second is a rig created in 4.2 and open in 4.2

In the 4.2 rig the belly has no secondary motion. It rigidly follows the hip area, whereas the 4.0 rig works as it should.

http://www.hollybush.btinternet.co.uk/rich/belly4_0.jpg


http://www.hollybush.btinternet.co.uk/rich/belly4_2.jpg

As you can see there are some differences. Any help dudes. :)

Thanks again! :)

Ablefish
12-15-2004, 11:34 PM
I won't have a chance to play around with the new system today, Pilchard, but you're probably best off giving the new features manual a read to find out how the new system works. (Maybe the stiffness? Though it would be odd to start it that immobile.)

http://www.softimage.com/products/xsi/v42/Documentation/features.pdf (http://http://www.softimage.com/products/xsi/v42/Documentation/features.pdf)

JoeW
12-16-2004, 03:42 AM
This may be a totally stupid thing for me to suggest - so don't feel insulted - but make sure you don't have "CnsComp" clicked - it will "break" all kinds of things in rigs - or at least make them appear to not work.....

JoeW

superquadric
12-16-2004, 07:30 AM
Hi Pilchard,

i am relatively new to this forum, actually this is my
first post but i had the same problem and think i found a workaround
- at least for Foundation users...

Softimage changed the way the belly (and tail and ears) option works
for the rigs in 4.2.
I believe in 4.2 the belly option now uses the Rigid Body Spring Operator for the
movement and since I'm working with Foundation and don't have Rigid Body Dynamics,
the belly, tail and ears options didn't work anymore.

After trying several things i just tried to overwrite the "makeBelly.js" and "makeTail.js"
(Location: X:\Softimage\XSI_4.2_Foundation\Application\DSScripts\CharacterRigging\)
with the same scripts from 4.0 and now it works as it used to...

Hope i could help

Eric

suppjj
12-16-2004, 09:23 AM
I noticed this in Foundation when 4.2 was first released but didn't realize it occurred in the other versions of XSI. The belly effectors spring rest position channels (upper & lower) need to have expression to follow the effectors global position the easy way is to drag and drop the respective channels to there influence. Remember to show all nodes in the explorer or these options will not show up also, to do it to both upper and lower. I made some scripts to automate this but they are made to create from guide. They can be found here if you are doing any more rigging. http://jnorombaba.com/dl_files/XSI/Scripts42.zip (http://jnorombaba.com/dl_files/XSI/Scripts42.zip)

I hope this helps JJ


http://jnorombaba.com/dl_files/XSI/Spring.jpg

Pilchard
12-16-2004, 11:24 AM
Thanks JoeW, not silly at all! It was off though, but know from experience how easy it is to forget simple things when troubleshooting! :)

J_j, you da man! He's all fat and jiggly now! Seems strange you have to set this now to get any wobble at all though!?!

I do like to know whats happening under the hood a little bit, am I right is assuming that the part of the belly that controls that part of the mesh wasn't following the spring operator to start with?

Cheers guys, I owe ya a beer next time I get stateside, hehe! On with the project....

:)

CGTalk Moderation
01-20-2006, 04:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.