PDA

View Full Version : Navigation workflow question


MJV
12-14-2004, 07:40 AM
I am using the S key to navigate which is ok but one thing I can't figure out is this:

Say I have an object selected and I start to transform it some, but midway through I realize I need to pan left a little to see where I'm going. So I hold down the S key and pan a little. Now when I release the S key, the transform key is no longer active. So I have to reactive the translate tool, which is not a desirable workflow.

My question: How do I navigate without dropping out of the current mode that I'm in?

Ablefish
12-14-2004, 08:27 AM
Hmmm... that really should work. If I'm in transform mode (I've clicked it - not just holding v down) and press and hold S, it will put me in navigation mode until I let s go, at which point it drops me back to transform mode.

I don't even know of any preferences that would mess this up...:shrug:

Vertizor
12-14-2004, 04:11 PM
I'll second what Ablefish said. It works for me exactly as he describes it, and I very much like this workflow. My left hand hovers over the left side of my keyboard more naturally as opposed to farther left or off-centered just to reach ALT for viewport nav.

SpeccySteve
12-14-2004, 04:18 PM
Under Preferences > Interaction > Tools, make sure the "sticky tools" checkbox is enabled.

Ablefish
12-14-2004, 04:42 PM
I think sticky keys is actually the part about clicking a key and having that mode or tool stay active. The holding a key down for temporary activation is referred to as Supra keys. But yeah, that's where I was looking for a pref too.

SpeccySteve
12-14-2004, 04:43 PM
Ah I see, I always get terms like that muddled.

MJV
12-14-2004, 11:24 PM
Thanks for the replies so far. It's very reassuring to hear that it's at least supposed to work. Looks like I'm the only one who has this problem. Following SpeccySteve's advice I discovered that sticky keys actually does have something to do with it. When I turn sticky keys on, it stops working as you guys say it works for you. When I turn sticky keys off, it works more as expected, but with some slight glitches in the display. This is not really a happy solution for me though because I like sticky keys very much and wouldn't want to have to disable them.

ThirdEye
12-14-2004, 11:41 PM
Have you already upgraded to 4.2 Michael? Also does the problem arise also when ZOPLing?

MJV
12-14-2004, 11:51 PM
Have you already upgraded to 4.2 Michael? Also does the problem arise also when ZOPLing?
Yes, already upgraded. And yes, after any of those keys is held down and then released, either briefly or long (I don't even have to navigate) the transform tool is disabled.

ThirdEye
12-14-2004, 11:59 PM
so it goes back to the selection tools?

MJV
12-15-2004, 12:03 AM
so it goes back to the selection tools?
Yes. This is so weird. Tested XSI4.0 and it's the same there. I even tried a different keyboard but no difference.

ThirdEye
12-15-2004, 12:06 AM
try it on a different pc, maybe it's got something to do with your keyboard settings in Windows (just trying to guess)

SpeccySteve
12-15-2004, 12:09 AM
Might well be something like that, certainly worth checking out.

MJV
12-16-2004, 09:54 AM
try it on a different pc, maybe it's got something to do with your keyboard settings in Windows (just trying to guess)
Thanks, but I have just one PC that I can install on, a Dell dual Xeon, and I'd kind of like it if it worked with that one. I'll try contacting XSI support in the morning. I hope they don't tell me I need a support contract to get help.

MJV
12-17-2004, 03:22 AM
I finally discovered that the problem stemmed from the KVM switch I am using. PS2 keyboards pluged into the switch have this problem with XSI, but I discovered that a USB keyboard works fine, so all I need do is replace the PS2 keyboard with a USB keyboard.

CGTalk Moderation
01-20-2006, 05:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.