PDA

View Full Version : Site loading takes forever


klingspor
11-28-2004, 12:35 PM
Over the past week or so the site has been unbearably slow for me. It can take up to several minutes for the start page to load, during which for some reason the browser tries to reflow the layout several times.

The list of subforums gradually appears one by one, only to disappear completely shortly after. Then after hitting reload, the page will eventually display, but obviously it's not much fun to browse this way.
The problem appears mostly on the homepage and the "new thread" areas, whereas threads and subforums load relatively quickly.
I'm on Firefox 1.0 and have been for a while, the problem only appeared about a week ago. Other site are snappy as ever. I've already tried obvious things like clearing the cache.
And it actually happens on more than one computer at different locations. Sorry, I don't have access to other browsers to verify the problem.

Note that I do not get the dreaded "Server Busy" message, so I somehow doubt it has something to do with server load... any ideas?

Mibus
11-28-2004, 11:59 PM
stefanminning,

Can you let me know what time(s) you're having difficulty?

If the problem is on our end (does anyone else have trouble right now?) it's probably related to inter-server bandwidth, which does run low at times.

We're going to be switching to new servers with 100Mbit interconnects for CGTalk and CGNetworks as soon as we can, probably in about another week. That should resolve the bandwidth issues - but whether that helps you is another matter!

On the front page is currently this text - Most users ever online was 1497, 11-23-2004 at 03:35 AM. - CGTalk usage has been increasing rapidly, which may help explain your issue.

Dave Black
11-29-2004, 12:05 AM
Mibus, I've been having a similar problem with Opera 6.

The front page opens, but then reloads over and over and over. Something is really wrong. I have checked this on my laptop, my desktop and my workstation at work. I've also tried it on a friend's computer. There is definately something wrong regarding Opera.

Oh yeah, and the formatting on the front page(for the banners) has been way off and out of alignment for awhile. I'll upload a pic if you need it.

-Dave

Mibus
11-29-2004, 12:22 AM
Very weird.

If you post the pic I can take a look at least :)

Dave Black
11-29-2004, 01:04 AM
Here's the visual on the top part.

I don't think the two problems are related though, as the reloading forever bug started happening last week...maybe a week and a half ago, and the top of the page bug started maybe 3 weeks a go or more.

-Dave

Mibus
11-29-2004, 01:21 AM
I just downloaded Opera (7.54 on XP) and it displayed everything fine.

Hmm

Dave Black
11-29-2004, 01:31 AM
Yeah, I've tried it on 7 at work in it's fine. Looks like it's only opera 6.

Guess it's time to upgrade.

*sigh*

Of course, I can't believe there would be any problems with Firefox...We have a ton of people using it right now...

-Dave

Mibus
11-29-2004, 01:40 AM
Problems with Firefox would likely be noticed before problems with IE; Both Leo and myself use Firefox :)

klingspor
11-29-2004, 08:42 AM
The problem doesn't seem to depend on the time of day, it happens pretty much whenever I visit the site, whether from uni, home or from work. Although I've noticed that occasionally it'll load flawlessly :shrug:

The times I generally tend to browse CGTalk range from 9-22 CET, if that's any help... and I'll try another version of Firefox later today, maybe something's wrong with my install. Though as I already stated, every other site works fine so that's not likely the cause...

I'll let you know when I find anything!

klingspor
11-29-2004, 05:45 PM
Alright, sidegrading to another Firefox build seems to have alleviated the problem somewhat, although the site still feels a little sluggish.

At least it doesn't reload for no reason anymore so it's useable again.

Mibus
11-29-2004, 11:42 PM
Anywhen you have trouble, check out the "number of users online" on the front page.

Normally everything is perfect until around 900, then it'll start slowing down slightly. 1100+ it starts to be more noticable.

Like I said though, we're upgrading servers, bandwidth, and software Real Soon Now :)

CGTalk Moderation
01-20-2006, 01:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.