PDA

View Full Version : transform problem during animation


TheShaddix
11-21-2004, 10:20 PM
Here is the problem: i have a steering wheel and it's constrained to its parent (a null), the whole thing is tilted 15 degrees. Now i want to rotate the wheel and animate it, so i rotate the null along its local axis and it works perfect, then i try to animate it, i insert a keyframe at 0 then slide it to 30, rotate the null some degrees, set another key there, but when i play it the wheel just doesnt rotate like it should (it looks more like it rotates along its global axis). I tested the same thing in a new scene and it worked as it should, but in my current scene something is wrong. I've been trying to figure it out- no luck. If anyone can help me out, id appreciate it.

Ablefish
11-22-2004, 02:43 AM
Kind of tough to troubleshoot this from here... :) But here's some thoughts...

If you select the null and (with child and constraint compensation off) rotate it locally, you should see the movement that is being saved in the fcurves.

You could be getting into trouble if you're doing both the 15* inclination and the wheel rotation - to be safe you might want to parent an additional null in there and seperate out the rotations. Or, change the order of rotations within the kinematics ppg of the rotating null.

TheShaddix
11-22-2004, 03:58 AM
i forgot to mention that when i create a new object, like a cylinder, just to test it, it still manages to not work right (i tilt it, then rotate it). It works fine when u rotate it, but when u playback the anim. it does the same as the steering wheel with its null. WHat could it be ? Could it be some animation option somewhere ?

CGTalk Moderation
01-19-2006, 10:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.