PDA

View Full Version : problem about a famous tutorial


onyxlee
11-14-2004, 02:47 PM
while study the famous tutorial by J.S.Rolhion named Warrior, which is about Zsphere, i followed every step and used exactly the same parameters with the tutorial.

but when i sculped the armor, i found my mesh has too little polygons to make fine details and smooth surface. so i raised the density of adaptive skin from 5 ,which is what the tutorial suggested, to 7. that made a 230000 faces mesh. it's too huge for me to export obj file. finally, i got a 40 MB obj file and max cannot deal with it smoothly. but i still cannot get to my goal, to get details and smooth surface.

can you guys help me out? all of you are masters of ZB, only i am still a newbie. i am looking forward to any suggestion. thx alot!

onyxlee
11-14-2004, 02:54 PM
btw, both of above are my practice mesh. the golden one was rendered in max using scanline. the blue one was rendered in zb. no matter how i set the antialias, the edges are not neat. i used the best render mode. how can i improve it?

in the above pictures, you can see the star at the stomach is lack of details. this part was made in projection master. again, the result of that tutorial is much much better than these two.

why? i've already put the divide level to 7!!!

help me guys!

ThomasMahler
11-14-2004, 03:27 PM
Do you mean the shading of the model? When you export it out of ZBrush, you'll most likely get a flat shaded model - That's what you see here. AFAIR in Max you have to add a "Smooth" Modifier, to turn on Gouraud Shading - Cause I don't see too many jaggies here.

In ZBrush, you can turn off Quick Shade Mode to get the same results. Hope that helped, your question wasn't not very clear...

onyxlee
11-15-2004, 12:40 AM
after i posted the original author's artwork, i think maybe i can figure my problem out.

here it is.

http://206.145.80.239/zbc/attachment.php?attachmentid=760

you see? not only the star at stomach, but also those tiny rusty details! in that tutorial, they are made by projection mster, but i can get nothing detailed out of the projection master. i think maybe because of the lack of polygons.

i just dont understand, is that necessary to put subdivision level to 7 in every project? it seems not even enough!

by the way, i tried good guy Thomas Mahler's method, and here is the result.

TVeyes
11-15-2004, 10:05 AM
It is not always necessary to reach subdivision level 7, 4 might be enough or maybe you need to divide to level 9. It all comes down to how many polygons you have in the specific area you want to detail with Projection Master.

J.S.Rolhion (STRIKE), the author of the tutorial, stays within zbrush when making his pictures. He therefore has the opportunity to disable Transform > Quick 3D Edit and enable Tool > Display Properties > Dsmooth and Dres. That will divide and smooth the polygons at draw time but will not effect the actual amount of polygons. That allows you to build smooth non faceted pictures within Zbrush.

Apart from that 230000 polygons is not that much:) Go to your highest SubD level and disable/enable the Polyframe(wireframe) viewing. That should give you a good idea of what kind of detail you can achieve at the current polygon density.

The Tool > Display properties only take effect when you have Quick 3D Edit and Polyframe viewing disabled.

onyxlee
11-15-2004, 01:22 PM
thank you, TVeyes!

your suggestion about smoothness is good for rendering. but i can still not use projection master to gain fine details.

the left one is my work.

after i picked up, the projection master transfered the painting to the mesh. and it is the right one.

so, i think, maybe the amount of polygons is still to low.

i gave it a try, a very simple mesh generated by 3 zspheres must be set up tp 7 to 8 subD lvl, the projection master can have some use to give details. (i dont mean texture map, but real mesh details.)

btw, how to increase the subD level of a certain part of a skin?

looking forward to any help! thanks!

ThomasMahler
11-15-2004, 02:13 PM
Yeah, the problem is that the model still hasn't enough polys - Projection Master makes sense when you're really into highly-detailed polyModels, otherwise you just won't be able to pick the details up again. So, when it comes to projection master, the more polys your mesh has, the better (of course, if there's enough detail in the area you're painting on, you won't have to be in million-polys regions for the whole model...).

So just go to an even higher SubD Level and export the lowPoly + the Displ. Map to render your model in Max, that's the way to do this stuff.

onyxlee
11-15-2004, 10:12 PM
Yeah, the problem is that the model still hasn't enough polys

yes, that's right. but what makes me confused, is why? i've seeked help in zbrush central, guys there seemed never have this problem. i followed the same tutorial with theirs, the official practical manual of zbrush, why cannot i get the same result? even i increase the subD level to 7, i can still not have that dense mesh.

i guess maybe there are some criticle steps the tutorial author didn't mention? and everyone except me has already figured that out?

btw, how can i increase the density of a mesh's certain part, but not whole mesh?

i know, it's not easy for me to fig out my question.

thank you guys again, for your patience.

onyxlee
11-15-2004, 11:24 PM
i kinda made it out. i just found that if in the adaptive skin mode, i couldnt subdivise a part of the mesh.

but after i converted the skin to a polymesh, i can either use mask or hide un-needed part to subdivise the part i want.

is that correct? is that the steps which the tutorial missed?

or, how did any of you do this?

btw, can anyone tell me how to easily select a single group of a polymesh, so i can spend less time on painting the mask or hide-unhide the mesh.

aminuts
11-16-2004, 07:53 AM
Yes, if at density level 7 and preview mode.....going to tools>geometry level 7 your mesh is only 230000 polys then turning it into an adaptive skin is the way to go so you can subd more.

if you turn on quick and frame while in edit mode you will see the groups created by the zspheres. Ctrl-shift clicking on the group you wish to edit will choose that group and hide the rest.

if you plan to use in max or whatever....when you make your adaptive mesh on subd level 1 make sure to store it as a morph target. then sculpt away and create a displacement...plenty of tutorials on how to do that at zbc. then use the displacement for the low poly version in your chosen program. that way you have a low poly model to import and a displacement map to return the detail you put into it. Check out the zscripts included with z2 as well about displacement maps.

hope something there helped.

CGTalk Moderation
01-19-2006, 10:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.