PDA

View Full Version : Would like advice on deformations at bends?


HellBorn
11-09-2004, 09:46 AM
When just putting a sceleton inside my models I allways get results that I dont find to be god enough.

From what I have used in other applications and seen In a XSI tutorial I'm looking into using either a cluster and modify the vertices and connect them to a bone rotation or to set up some kind of muscle bones.

I did give the cluster solution a try. I did bend the bone about 20deg and adjusted some vertices and save(dont remeber the correct name of the command) that then moved the bone to about 40deg and added some more adjustments.

Problem is that now when i bend the bone, at 0deg it looks as it should, when getting close to 20deg the vertices suddenly moves to where i wanted them, short after passing 20deg they move back. When getting close to the 40deg position the jump into place again and when passing 40deg the modificaton once again dissapears.

What I want is of course that there shold be a smooth transiton between the modifications i made at the different bone positions. How do I get that?


The other solution is something I have not tried yet as I so far not found any tutorials about how to add constrains that make make a bone that streches itself in order to connect to a null or make a bone slide along the orientation of another bone or how to make a bone orient like another bone etc.

Any suggestions on where to start in order to understand more on this?


Or any totally different solutions on how to fix it?

Ablefish
11-09-2004, 05:02 PM
One thing you may not be aware of is that you can use almost any object, including implicits, as deformers in an envelope. Basically anything with a center, since the envelope basically sees bones as center anyways.

But in terms of your deformer problems. A couple of things are important when you're using "Link Deformer With..." Always make sure you have the cluster selected when you "Save Deform Key". This will make sure that the command is recalculating the weighting of the different deform keys associated with that cluster. You want to make sure that all the keys are being saved and mixed in a single compound clip. If not, you'll have competing shape tracks, which sounds like the case with your jumping shapes.

Also, you don't need to save a Deform key for the at rest position (just do "Link Deformer With..." at this point). I only mention this because in some softwares this might be the case - in XSI, shape animation is relative to the state of the modeling stack, not to a neutral shape key. If you do it in XSI, that neutral shape will dilute the later shapes.

If you're going to try this 'from scratch' on your model, make sure you delete the custom parameter sets that were created under the cluster before re-applying "Link Deformer with...".

In the manual (and I hate XSI's help search engine, btw...) look for the section "Linking Deformations with Parameters" in the Shape Animation section for a walkthrough.

EDIT: Oh yeah - make sure you're making and saving your shapes in Secondary Shape Mode!

Hope that helps,

HellBorn
11-09-2004, 06:26 PM
Ok. I will give the deformer a new try, could be that I did some of the things that I should not do ;)

From what you tell me I suppose that if I did do it the right way I should get a smooth transition between the shapes. Is that correct?

Now that I now a little more about what I'm looking for I found some more in the manual and on the tuturial DVDs that I will read.

Ablefish
11-09-2004, 07:12 PM
You should get smooth transitions, yes. Let us know how you make out.

CGTalk Moderation
01-19-2006, 09:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.