PDA

View Full Version : Linux: change keymap for X?


schmu_20mol
11-02-2004, 07:33 PM
How or where do I change the keymap for X b/c mine went away from nodeadkeys(de-latin1) when switching from KDE to Blackbox. What also may be the issue that it went from 104 to 105 keys I dunno (the not working key is on a qwerty layout between the z and the left-shift)

...long story short...I'd need the de-latin1-nodeadkeys.map back at least that's what I assume

btw...I'm using Yoper...

any help appreciated...thx

elvis
11-03-2004, 01:16 AM
Check the x.org documentation for the "keyboard" driver:

http://www.freedesktop.org/~xorg/X11R6.8.0/doc/keyboard.4.html

In particular you'll need to modify your XkbRules, XkbModel and XkbLayout options.

Once you get X working the way you need, always make a copy of the xorg.conf file for safe keeping. A lot of Linux distro update tools tend to overwrite this file without asking, which is very annoying. I always keep a backup copy of my config files on a separate system just in case an update goes astray.

schmu_20mol
11-03-2004, 12:25 PM
well in my XF86Config is


...
Section "InputDevice"
Driver "Keyboard"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "de"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
Option "XkbVariant" "nodeadkeys"
EndSection
...


which I'd assume pretty correct but nevertheless the keys not working

lots
11-03-2004, 12:52 PM
Thought you said that you had a 105 key layout?

CGTalk Moderation
01-19-2006, 06:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.