PDA

View Full Version : Networking 3 pc's through router on XP


jcbray
10-27-2004, 02:37 AM
Hey all,

I'm trying to network my 3 computers through my router. I already have the internet going through the router, so all pc's, regardless of which other computers are on have access to the 'net, but I would also like my computers to be able to see each other so I can transfer data more easily, especially since one computer only have a CD-reader.

The network card is a Realtek RTL8138/810x

When I run the Network creation wizard, I choose the option for using the router with the internet connected directly to that, and proceed, but no other computer is ever seen. And yes, I have tried this with the other computer's on.

I have "file and printer sharing for microsoft netowrks" under my only network connection checked, and thats on all computers aswell. I did look around for some guides, but the ones i found were simply guides to using the netwrok creation wizard.

If anyone can offer some ideas or a clear set-by-step guide to help me with this, it would be greatly appeaciated, as it seems it's either a complex problem or i'm missing some very simple step *shrugs*

Thanks to anyone who can help me, if there is some other infomation you want, just ask and i'll do my best.

- Colin Lynch

novadude
10-27-2004, 03:01 AM
Have you assigned all of the PC's to the same workgroup?

jcbray
10-27-2004, 03:09 AM
Yes, each computer is assigned the same workgroup, and each computer has a different name. Thanks for helping

Tarrbot
10-27-2004, 03:20 AM
Do you have XP's firewall turned off on your machines?

jcbray
10-27-2004, 03:52 AM
I don't believe I have it running, however, my only network connection says it is firewalled, I can turn this off, but performing the network creation wizard puts it back on.

I just double checed by turning that firewall off on both ends and doing it again; didn't work.

Where is the option to enable/disable windows firewall?? maybe the firewall i'm talking about is perhaps a different one? I acces the one i'm talking about my going to the properties of my network connection and going to the 'advanced' tab.

singularity2006
10-27-2004, 05:09 AM
this is one of those reasons I hate XP wizards. To get it solidly right the first time around, u gotta do this (there are two ways, this is the manual IP assignment way ... best way to do it in small networks in my opinion):

start menu > control panel > network and dialup connections > right mouse click: Local Area Connection.

Double click TCP/IP. Under the IP address information, apply the following:

IP: 192.168.0.1 (for the first 3 sets of numbers, use the address of the router)
Subnet Mask: 255.255.255.0
Gateway: IP # of the router

Go to your router, if there is a MAC Address to IP mapping function, map the MAC addresses to the IP addresses manually. All the computers should be able to see each other as long as they're within the same address range: AAA.BBB.CCC.###, where ### is any number between 0 and 254.

To get the MAC address, go to start menu > programs > accessories > command prompt > type: ipconfig /all <enter> and look for the ##-##-##-##-## code... it's usually listed right next to the name of the network card.

Anyway, the problem is that the IP number pool gets really screwed up when doing DHCP from the router and XP has a hard time opening up sharing between PC's. U gotta get the proper IP numbers from the router in order to get sharing to work properly. Sometimes it just won't work and u'll have to resort to manual IP assignments. In most cases, it should work because routers generally give the right AAA.BBB.CCC.### IP number to each computer. Sometimes it doesn't, then u got a problem.

YankyBJeans
10-27-2004, 07:46 AM
can you explain why it would work ok without doing all that, when using one windows 2k machine and one win 98 machine on a router, but then not work later when only using 3 win 2k machines? I had my network at home sharing an internet connection with my parents machine and mine and i didnt have to do anything other than put us both in the same workgroup. However, now all my machines are win 2k and although they can get online, they cant see each other. All are properly shared and setup as Ive shared them all before through a switch, just not through this router.

Sounds just like jcbray's problem, so Ill probably look into setting things up the way you suggested, but was just wondering why it would work ok with no setup and then not, once a few things were switched around.

Yanky

jcbray
10-27-2004, 08:25 AM
YankyBJeans - I've fixed my problem...sort of

First I tried to follow the steps singularity2006 gave me, half the steps i had already done to set up broadband thorugh the router anyways - but when i went to the IP mapping thing in my router config place, setting that up caused my internet to drop out. So i undid those changes and went to my LAN settings and set that part up.

Sorry if i'm vague, working off memory, but if you do have that LAN option, don't disable DHCP, check it to lease forever, and change other settings to suit ur set up and then apply it, then run connection wizard if you can't see your toher computers.

Now, my problems arn't completly solved. Computer one can see computer 2 only; computer 2 can see pc1 and pc3 but only acces pc3; pc3 can see both pc1 and pc2, but only access pc3.

I'm on pc1 - the shared folder is set to be shared over a network, but for some reason the other computers can't access it, it says access is denied, contact computer admin (me :P)

jcbray
10-27-2004, 10:44 AM
Argh - this is quite annoying - by adjusting the LAN settings of my router, I was able to have my computers see each other, however, they all say that I don't have access when I click on one of them.

The shared documents folders are set to be shared and modified over the network, but all computers say they don't have access - any ideas??

Sieb
10-27-2004, 04:47 PM
Anyway, the problem is that the IP number pool gets really screwed up when doing DHCP from the router and XP has a hard time opening up sharing between PC's. U gotta get the proper IP numbers from the router in order to get sharing to work properly.

Um.. No.. Never encountered that problem before, thats all rather extensive and unneeded directions that can cause more problems later on. Leave all machines to used DHCP and let the router do all the work. No need to use windows wizard either. And if your running a router, there's no need for windows Firewall to be on. Are all the machines on the network XP? If not, its a little more work than just sharing a folder.

http://www.windowsnetworking.com/j_helmig/wxpsimsh.htm
http://www.windowsnetworking.com/j_helmig/winxppro.htm

singularity2006
10-27-2004, 04:48 PM
Out of curiosity, are all the computers set to use the same password? If not, are u seeing a user login screen when u try to access them or is there absolutely no trace of them at all in the network folder?

Yeah, the DHCP lease thing works too. If your router has a setting for it, there should be one that forces the DHCP to always give the particular MAC address the same IP everytime. As for the reasons why stuff doesn't work, there's so many reasons that can cause it. Most of it is security and firewall issues between the router and the system. In my old router, there were options of allowing the computer access to the internet but disable association with other computers on the network. However, that is only one of the many causes. The other instance is that some computers might be missing the particular services required for ensuring normal operations of file sharing. In that case (for both Win2K and XP), go to:

start menu > control panel > administrative tools > system services

Be sure u have the following services set to run automatically:

Workstation
Computer Browser
Network Connections
Remote Access Connection Manager
Server

WinXP has a plethora of other services that I am not familiar with. However, in my own cases dealing with Win2K, ensuring that those particular services are enabled work well enough for me.

singularity2006
10-27-2004, 04:52 PM
Er.. Never encountered that problem before, thats all rather extensive and unneeded directions that can cause more problems later on. Leave all machines to used DHCP and the router will assign all the TCP/IP settings needed to see the internet.
Yeah, I've worked with some really weird routers. There was one generic they told me to play with the for some reason gave everyone different IP numbers but only used the first two digit sets the same.... gave us AAA.BBB.###.###.... totally got weirded out. Anyhow, I personally use fixed IP mapping in small networks to cut back on the overhead necessary to pull an IP. On larger networks, yeah, u'll definitely want DHCP. But 10 computers or less, I'd stick to a fixed IP scheme. Sometimes the DHCP gets weird and won't give an IP... I've had that happen on a couple of routers too. Such a hassle to reset.

Sieb
10-27-2004, 04:55 PM
Sig.. your thinking too hard. :P

Its a security issue between the machines, not a network problem. If the machines aren't all XP, then you either have to force Guest or add the computers accounts to the XP machine for authentication. See the links I left above.

Sieb
10-27-2004, 05:00 PM
here was one generic they told me to play with the for some reason gave everyone different IP numbers but only used the first two digit sets the same.... gave us AAA.BBB.###.###.... totally got weirded out.

Subnet 255.255.0.0 instead of 255.255.255.0? :)

There is no overhead for DHCP, its part of the network protocol. No need to map IPs, most routers don't start DHCPing till after x.x.x.100, so just uses a static address of x.x.x.2-99 along with the external DNS IPs. Your making things too difficult on yourself. :P

singularity2006
10-27-2004, 07:32 PM
Subnet 255.255.0.0 instead of 255.255.255.0? :)
Your making things too difficult on yourself. :P
actually, no... subnet was okay. But the thing actually gave us weird IP's.... AAA.BBB.###.###...

And heh, yeah, mebbe things are difficult. Just one of my idiosyncrasies.

jcbray
10-27-2004, 10:50 PM
Sieb - I tried to follow through that guide with 'cacls'? in it, but it was quite confi=using for someone who isn't that computer literate - i'm not a complete fool when it comes to computers, but that wasn't something I was used to.

I can now see the other computers, but clicking on their shared folder causes the window to stop responding, or to sometimes say access is denied. *shrugs* the folders are set to be shared though

Sieb
10-28-2004, 02:22 AM
Are all the machines XP?

jcbray
10-28-2004, 02:31 AM
Yep, every PC is windows XP

Velk
10-28-2004, 02:59 AM
Are you running XP Home or Pro? That can make a difference. The only thing you need to do is have the same user name on the computers. For instance if you were connecting two computers you might have:

Computer 1 users; George, Kelly
Computer 2 users; Kelly

Now on the first computer make a shared folder that gives Kelly access.
The second computer should now be able to see the shared folder under My Network Places.

done.

jcbray
10-28-2004, 05:00 AM
My shared folders are set to allow Everyone access, seen as that didn't work i did try to add permissions for all of my user names, but that didn't wrok either. On this computer, tyring to open the other's shared folder makes the window stop responding and it closes, on the other computer, accessing this one, I have an access denied error pop up.

And it's XP Pro

CGTalk Moderation
01-19-2006, 04:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.