PDA

View Full Version : Whole Head Jumping with Shape Key


AKS
10-19-2004, 11:05 AM
Hello,

So first a little background. I am trying to setup a character for a short. I modeled him in Zbrush, and I've exported his head to XSI 4 to do the shape-keys. Up till now I've been just pulling points till it looks like I want and adding them doing Shape->Save Shape Key. This has been working fine.

The problem comes when I went back to Zbrush and tweaked my model there for the eyes closed position. I imported the eyes closed mesh (.obj) back to XSI, moved it next to the main head and then did a Shape-> Select Shape Key. And this seems to work expect the main head jumps to the position of the newly imported head leaving it's chains, etc... behind. I am not sure why this is happening.

My main head mesh (where I am doing all the shape keying) is in a model and I've tried putting the eyes closed mesh both in that model and in the scene root to no avail. I have also tried importing the eyes closed mesh and not moving it. I am doing all of this in shape-modeling mode. I think at some point (a while back) I did freeze the transformation on the main head, could that be causing this? Any help would be appreciated. Thank you,

-- AKS
www.fiercefire.com (http://www.fiercefire.com)

titaniumdave
10-19-2004, 12:47 PM
Ok let me see if I understand you right. You modeled the head in zbrush then exported a obj that is imported into xsi, then you created the shape key, exported to zbrush, worked with it then imported again? Might have something to do with being a key and then being edited which is causeing the problem, no idea really. What you could try is import your originial model, duplicate it, then move points until you get your shape, then export that new model into zbrush and work with it there. Then after you get all your shapes created, import them all into your scene. Then click the orginial head and click shape, store shape key. Now with that head still selected click shape, select shape key and click all of your other shapes. Now all of the shapes should be in the mixer. You can then go into it in the explorer find the custer shapes and freeze them so you can then delete all the shape heads keeping the original with the blendshapes intact.

mattmos
10-19-2004, 01:11 PM
The reason for the shape moving would be that the centres of the objects don't match, or that the tweaked object has a different vertices count to the original. I don't know if tweaking in zbrush would add any more polys to the object?

One solution if the centres are different (maybe not the best but it works) is to go through each head and match the position of the centre to a vertex in the head which you know hasn't changed position, and then freeze the heads. If you then re-setup the shape animation it should work ok...

AKS
10-19-2004, 02:40 PM
Hey, thanks for the responses. Yeah, when I lined up the models they did just fine. Thanks for the quick responses. Just for general info Zbrush dosen't add any polys to an imported model unless you tell it to. Thanks again,

-- AKS

Sil3
10-19-2004, 02:58 PM
Did u moved the objects inside XSI? When i say moved i mean if u picked up the object and moved it? If so dont do it, select the Points and move the entire object in Point selection mode, this way your object center wont move, since what u are moving are the components and not the object itself.

CGTalk Moderation
01-19-2006, 02:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.