PDA

View Full Version : character animation problems


saajjj
08-18-2002, 02:11 PM
hello,
I've modeled a simple monster with arms and legs.. no spine. it's like a sphere with four limbs. I've attached a skeleton to it but when i try to animate it, the whole thing becomes extremely slow, much slower than when you put etho (by mike isner) and run script together. My model has lesser polygons than the standard man/woman model.

Could it be that the operator stack on the model is slowing things down? Right now the sphere has about 30 things in it's stack. Should i freeze them? Or is my skeleton bad??

And what is a rig? I've made a skeleton and put the rotation limits on it.. so i don't understand what a rig is, is it an extension of a basic skeleton or does it have to be made from something else?.. please explain someone.

thanks v much

acidboy
08-18-2002, 02:39 PM
Hi saajjj :wavey:

First things first, yeah you sould definately freeze any history\operators on your objects that you don't need.
Eg, modeling history. But naturally don't freeze any operators that you need to deform the character, like enveloping.

My guess is that the history on your objects is the main problem for it being so slow.

Yeah a Rig is basically a 'complete' skeleton setup, with all it's extra deformations (facial, muscle, joints, secondary motion) and refined contols added. This can also involve scripting and what not, to also add automated controls n stuff, making the character easier to animate.

So that's it in a nutshell I guess.

Hope I helped :hmm:

CGTalk Moderation
01-13-2006, 03:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.