PDA

View Full Version : help: rigging probs (bones stuffing up)


ninoaniceto
10-17-2004, 05:09 AM
hey,
ive got this problem with my bones. id move a IK bone-controler and the some bone wont follow. but when i render its seems ok. im not sure why this is happening. also if i scrub the the animation really fast - it fixes it self. im thinking that its just LW updating things really slow.
im just wondering if this will cause porblem later on?
and, is there are a way to fix this?
has this ever happened to you?

any help would be great.

ive indluded a pic to show you.
http://www.3dfightclubforum.com/phpBB2/files/rig_prob2.jpg

kevman3d
10-17-2004, 10:34 AM
I've seen similiar problems - Once I parented a pile of layers to bones for a mechanical character - However on rendering, intermittent frames would show the layers occasionally 'dislocating' themselves then reconnecting at the next.

I switched on Motion blur, and sure enough - 'Pop' - Every so often the layers were still dislocating, even when being rendered (I could see them happen in the motion blur). Very odd. In the end I just weightmapped everything and set the bones to use Weightmap only... It worked fine that way.

You sound like you could be having a similiar problem? Scrubbing quickly may just 'skip over' the problem - It may still be in there...

How have you rigged your character?

ninoaniceto
10-17-2004, 11:13 AM
ok people. dont stress. ive figured out why it happens and how to fix it. you basically have to redo your whole skelogons all over. or cut and paste each one into a new layer and merge then back (this also makes each one you cut and pase the order your bones will be when you select them in layout). ive always known this method but i was hoping someone will know a better way on how to fix this....and as to why it happens....im still not sure. but who cars now? i've fixed !
cheers anyways.

kevman3d - i made skelegons then converted them. and used IK on his legs.

CGTalk Moderation
01-19-2006, 02:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.