PDA

View Full Version : Oh the Pain.......


acidboy
08-16-2002, 01:06 PM
Hey guys,

I seem to be running into some serious problems with my animated scene. Basically even when I have muted all softbodies and disabled them from saving to file. I am forced to save my scene at the first frame as otherwise XSI goes through and saves every softbodies simulation. Any ideas?

Though I can work around that

But now I realize that XSI is having problems even rendering a single frame when I am some distance past the first frame, and I'm thinking this is softbody related, as in XSI is trying to calulate the softbody simulations up to the the frame that I am doing a render on. I've got low res stand-in characters for my Hi Res ones, so the scene should render in like a second.

I've tried even deleting all the softbody operators and it still does it, so I'm running thin on ideas and patience.

Anyone have any possible ideas why the heck this could be happening. (maybe it isn't softbody related...though since I have used em in my scene it has caused may problems)

Deadlines for this project are approaching and I'm starting to freak! :cry:

dmonk
08-16-2002, 02:46 PM
maybe you should calculate up to the starting frame before you start the render other than that I don't know.:shrug:

acidboy
08-16-2002, 03:23 PM
yeah it totally whacked!

but yeah dmonk I'll give what ya suggested a go.

It's definately the softbodies as I've tried it on my home computer too, XSI doesn't seem to be able to properly disable softbodies. :thumbsdow

Even if I mute them and untick 'save simulation' on all the softbodies, it doesn't help.

The only way to fix the problem is to totally delete the softbody mesh\s. But that's kinda ummm.............NOT good!

For the love of god there must be a way to disable these evil evil things. :annoyed: :cry:

krisr
08-19-2002, 02:26 AM
plot the simulation as shape animation, remove the simulation. I recommend this before rendering.

acidboy
08-19-2002, 03:26 AM
cool thanks krisr
I'll remember that when it comes to final rendering time.

I'm only doing test renders at the moment, but it still tries to calculate the softbody simulation even when it's disabled.

I just tested an earlier verson of my character with softbodies influencing it, and I don't have the problem. Something has gone screwy when I imported the character into this new scene.
Just gonna have to delete the sofybodies objects and redo em later.

Now and then you get some really strange happenings in XSI....but I still love her.....ummmm...it! :p

zen
08-21-2002, 11:46 PM
if "save simulation" is off, then yeah, soft will have to recalculate everything from frame 1 EVERY FRAME in a cumulative manner until the last frame.

acidboy
08-22-2002, 04:33 AM
oh yeah I totally understand that :rolleyes:

The problem was that I couldn't actually disable the softbodyOp, even when muting it and disabling it in the explorer.

But I noticed that in another scene where I had the same character with same softbodies, I didn't have the prob.

So it musta been XSI freakin out again, ahhh well. Just have to recreate the softbodies in that scene. :hmm:

CGTalk Moderation
01-13-2006, 03:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.