PDA

View Full Version : Zbrush and xsi


Talking_Pie
09-29-2004, 05:13 AM
i've had a few problems after modeling in zbrush and then reexporting back into xsi and slapping on the saved displacement. if anyone out there is fairly well read in this area especially if they use xsi too i was wondering about specific settings such as
exporting from xsi settings
importing to zbrush settings
exporting from zbrush
and specific shader set ups for xsi to render out the displacement

i've looked through the pdf that comes with zbrush concerning xsi but it really doesn't help too much, if anyone has any knowledge that could help me out that'd be super cool hundred-percent.

thanks.

Talking_Pie
09-29-2004, 05:57 AM
here's what it looks like when i export my obj back from zbrush into xsi

combatmantra
09-29-2004, 08:33 AM
Hi, looks like a problem of the normals, look in xsi for a user cluster or something like this and delete it, hope this helps.

And about information about displacement or normal maps make a search in www.xsibase.com (http://www.xsibase.comthere) there are a lot of information there.

Cheers.

Talking_Pie
09-29-2004, 10:07 AM
pokay, thanks a bunch ill check those normals out too.

r3mix
09-30-2004, 01:34 AM
I have had models look the same way going from Max to XSI. Make a polygon primitive and merge the imported object (in your case the head) with the primitive and then delete the primitive by selecting its faces or with polygon island selection and your model should look like it is supposed to. Worked for me anyways. :)

Talking_Pie
09-30-2004, 03:05 AM
that's a really good idea, thanks

Waz
10-01-2004, 11:56 PM
When the Wavefront OBJ import dialogue box opens after selecting Import > OBJ, Uncheck 'Normal (different normal in user normal cluster)'

Should solve your problem without any extra work.

Talking_Pie
10-02-2004, 04:23 AM
oh wow thanks a bunch that should solve unnecessary work

r3mix
10-02-2004, 09:27 PM
Ahh good info. Not sure how I missed that myslef, but good to know.

dogBeer
10-03-2004, 03:47 AM
I thought displacement maps in mr would be easy - how wrong I was.

legylion
10-04-2004, 11:08 PM
Hi there Talking-Pie. There is probably nothing wrong with your model other than the way it looks when you first import it. When you first bring it into XSI, go to your "clusters/user normal cluster" folder in the explorer window. You'll find a "user normal" property in there that you can delete. Problem solved. The other thing you might want to look out for is UV flipping from zbrush to xsi as model orientation is often different progam to program. (upside down and/or backwards). You might be able to solve this in the preferences/import-export menu in zbrush but I find it easy and quick to just flip my corresponding maps in photoshop. If you still are having problems, check to see if you have smooth UV activated under tools/geometry in zbrush. This should make sure your UVs match you subdivided model back in in xsi. Hope this helps.

D-E-A-N
10-20-2004, 02:35 PM
hi there, you can also check the zbrush export settings, there you can flip and inverse the normals so that everything looks fine after importing to xsi :)

Talking_Pie
10-20-2004, 09:19 PM
okay yeah i didn't now much how those flipping things worked, ill give them a shot, killer, thanks.

LanceB
10-22-2004, 12:16 AM
I don't know what you guys are talking about? I like him... you could call him Obsidian Man!

DimitrisLiatsos
10-22-2004, 03:48 PM
When the Wavefront OBJ import dialogue box opens after selecting Import > OBJ, Uncheck 'Normal (different normal in user normal cluster)'

Should solve your problem without any extra work.

I am doing that all the time so i think it wil help u too. Seems to be the faster way to solve this. For me it happens ( in a slight different way) when i import OBJ from Maya too, so i don't think it's a ZBrush problem...hope i helped.

willog
10-23-2004, 12:03 PM
Thanks Waz

Solved it for me anyways :-)

Muchas Appreciated

CGTalk Moderation
01-19-2006, 10:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.