PDA

View Full Version : Modo.cfg


ChristianFischer
09-23-2004, 08:49 PM
hi.

in my modo.cfg (C:\Documents and Settings\user\Application Data\Luxology\) i've got different lines saying "import/ ... /keymap01.cfg"
"import/ ... /keymap02.cfg"
i saved those keymaps and activated "import resulting file" so at every startup modo imports those keymaps.
the "import resulting file" option was activated by default so i didn't touch that checkbox.

now i want the keymaps not to get imported at every startup but i want the default keymap to be saved internally.
how can i achieve this?

also i am not able to save the keymap to a different location ... it seems as if modo only saves the differences to the previous saved keymap.

help is really appreciated :)

chris

markbrown
09-23-2004, 09:37 PM
You can just delete those import lines from your config and the key mappings will return to their defaults.

Yes, only the changes are saved, modo uses a layered config system where each config adds it's contents to other configs loaded previously. So your changes overwrite (on load) the settings read from the base configs.

Did that answer your question? I'm not sure I'm following what you're trying to do!

Pazur
09-23-2004, 09:47 PM
You can try to simply remove the import lines from .cfg.
You might also try to export keymaps again but with import resulting file unchecked. in case of layouts for example it removes exported layout from .cfg.
If You haven't modified anything but keymaps in modo You can also delete config file and modo will restore the default one during next restart.

ChristianFischer
09-23-2004, 09:55 PM
You can try to simply remove the import lines from .cfg.
i tried that but then my keymap is gone and i don't want to configure everything again.


You might also try to export keymaps again but with import resulting file unchecked.
i also tried that .. didn't work either. i always get a 58 byte file with this in it:

<?xml version="1.0" encoding="UTF-8"?>
<configuration/>
:shrug:

CGTalk Moderation
01-19-2006, 08:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.