PDA

View Full Version : diffusion shader connection problem


seb4d
09-14-2004, 01:18 PM
Hi !
I used the diffusion shader in xsi to create a skin shader for a bird. I connected the phong output to the diffusion's illumination input, then the diffusion output to the material's surface input. The rendering looked exactly what I wanted.

Now I'm trying to do the same in Maya 6.0 but have some trouble. I'm not very familiar with the hypershade, I find it more difficult than xsi's rendertree. I tried to do the same connections and I think I managed, but the render isn't exactly as in xsi, some parts of the mesh are very dark. The eyes that have an independant black blinn shader doesn't render correctly. But the most annoying thing is that the mesh as a transparent alpha channel.

Could someone help me fix those little problems, I don't have the skill yet to find my way alone in the hypershade.

Here is a screenshot.
Thanks !
http://www.seb4d.com/divers/diffusion_problem.jpg

Jozvex
09-15-2004, 05:54 AM
Hi there,

I only have limited experience with XSI (I have the Foundation Demo and the Half-Life EXP version) but I noticed that in XSI you start with some ambient light already in the scene, so maybe it looks darker in Maya because Maya has no extra lighting besides the lights you place yourself?

And for the Alpha channel problem, you could either pipe the Diffusion shader into a Surface Shader node (rather than going straight to the Blinn's Surface Shader slot, they're two different things) or in the Render Globals under Custom Entities, turn on Pass Surface Color Alpha, meaning the alpha channel will be derived from the RGB image.

:)

Panupat
09-15-2004, 10:03 AM
can I see the render done by XSI?

seb4d
09-15-2004, 12:38 PM
Hi Jozvex,

I tried to plug the diffusion shader into a surface shader and activated "Pass Surface Color Alpha", it works ! Thanks.
As for the default ambiance light in xsi, I haven't tried yet in maya.

Panupat here is a screenshot from xsi :
http://www.seb4d.com/divers/diffusion_xsi.jpg

dynamic duotone
09-15-2004, 01:37 PM
Very nice seb4d!

Could you post a screen shot of your diffussion shader settings?

Thanks
DD

seb4d
09-15-2004, 02:45 PM
Here it is, very basic parameters.

http://www.seb4d.com/divers/diffusion_xsi_shader.jpg

dynamic duotone
09-15-2004, 04:34 PM
Thank you very much, I really liked the way your shader looked...and was having trouble getting the same reaction, my settings were a lot different than yours.

Thanks again,
DD

Jozvex
09-16-2004, 02:52 AM
Oh I just thought of something else, in XSI I think that by default, shadow darkness/density isn't set to fully black whereas in Maya it is.

So in the Attribute Editor for the light, you could try lightening the raytraced shadow colour too perhaps.

:thumbsup:

seb4d
09-16-2004, 09:00 AM
Yes you're right ! I forgot about it too.
I think all these lighting parameters differences between maya and xsi are the key.

Thanks for your help !

CGTalk Moderation
01-19-2006, 06:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.