PDA

View Full Version : xsi 4.0 rendering problem


avmics
09-08-2004, 03:25 AM
The sphere and the model have the same material. Why is the model not rendering? The model is an imported polygon obj file. When a texture is associated the model renders with the color of the texture without 3d form it is rendered flat.
http://members.shaw.ca/avmics/Preview.jpg

Atyss
09-08-2004, 07:43 AM
Obj imports generally have inverted normals. Select all polygons and do Invert Polygons.


Cheers
Bernard

bravmm
09-08-2004, 07:48 AM
check the obj for clustermaterials. If so, they're overrriding the newly given material in XSI.

Hoipe this helps,

rob

avmics
09-09-2004, 02:58 AM
where are cluster materials located?

3DDave
09-09-2004, 03:48 AM
Go to the Scene Editor, open up the polygon mesh folder for the object.

Or a quick test would to assign a new material to overide the clusters. Get, Material, Phong for instance.

avmics
09-09-2004, 11:47 PM
I tried assigning a material, looking for cluster materials and inverting polys. Nothing resolves the issue.

wrosado
09-10-2004, 05:22 AM
I've had the same problems with imported objects showing up black. You can either select the object and right click the cluster button and delete the listed cluster....

or

On the import window, click the 'Import as Clusters' option. this works for me. I get the model imported with out being black.


hope that works.

NRat
09-10-2004, 09:48 AM
May be this may help you...
http://www.cgtalk.com/showthread.php?t=162355

gato
09-17-2004, 01:19 PM
Hello. I think the only thing to do to see in the rendering itīs to subdivide the mesh to any level unless zero. I found the same prolblem on a .obj object ( this time was a car ). Hope this help.

Ablefish
09-17-2004, 03:27 PM
That's not the only thing to do. If you can't find a custom normals cluster on the object, you can reset them yourself by selecting the edges and using the Modify->Components->Set Edge Crease value.

avmics
09-19-2004, 04:12 AM
thanks guys

deleting clusters or increasing the subdivide to something greater than 0 work well

CGTalk Moderation
01-19-2006, 04:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.