PDA

View Full Version : transparency problem in Mental ray


stephen_T
08-27-2004, 03:32 AM
i am making eyelashes, and assign a lambert and a transparency map to it,but when i render in mental ray, the transparency part of diffuse color is white and the alpha is not transparency. and my camera enviroment color is black, why?is it a mental ray bug?

BillSpradlin
08-27-2004, 04:40 AM
Did you try lowering your shadow attenuation to 0?

Daniel Whitton
08-27-2004, 05:15 AM
Did you also turn on PASS SURFACE ALPHA under the Custom Entities of your render globals?

stephen_T
08-27-2004, 09:35 AM
thanks for answer, but both methods arent work, and i figure out the white color is,it is the Env sphere(nurbs) color,i set the primary visibility off of the Env sphere,but it was also render behind the transparency. plz help~~~thx

francescaluce
08-27-2004, 12:09 PM
it seems that mr does not support scanline transparency in maya env when the last node is not a build in maya illumin material... at least this is where I discovered first time this issue.. check refraction (you know it's raytraced..).. under the raytrace panel.. just if you don't want to change the hypershade.. for simply eyelashes it is not a great disavantage :D... or redesign your shader.



ciao
francesca

zuao
08-27-2004, 02:27 PM
hi,

... the transparency part of diffuse color is white and the alpha is not transparency
What do you mean by that? The alpha is white and the RGBs are white?
Are that eyelashes a polyplane with a transparency map (like you said) or cones with a transparency map? Which version of Maya you are using?

Is your transparency map a file texture? What format? Try some other file format and ensure that it is in RGB Mode (24bit).

so far,
nando.

zuao
08-27-2004, 02:51 PM
Ah! sorry, now - after second reading - I understand the problem.
Yeah man, as you discovered the white in the eye lashes comes from your env sphere, besides the white alpha too. But that would be the wishful behavior because you got the secondary rays (refl, refr) in the diffuse part and the alpha is just white, because you need it white, if you want to composite ... if alpha would be black you wouldn't be able to composite a layer with refractive elements. Of course you could get a black alpha for your transparent elements by switching off raytracing (scanline = on) and set the matte opacity of your env sphere to 0.
nevertheless I could imagine that this explanations won't help you in the way you want things to be. If your problem persists, perhaps it would be helpfull if you post a screenshot. but know, it's not a bug, you are talking about. it's normal raytrace behavior.

ciao,
nando.

stephen_T
08-27-2004, 06:37 PM
thx all friends answer me , i still cant fix this problem by Turn on Scanline, the env sphere use MR shader.....yes this is raytrace problem,so when i turn off visble in reflect and visble in refract,the problem is solved,but the env sphere can not do final gathering....so ....i post my problem pic and the scene.plz help thx

slipknot66
08-27-2004, 06:43 PM
Well, i suggest you to delete your env sphere and use the new feature called Image Based lighting, so you can have much more control over the reflection/refraction.

slipknot66
08-27-2004, 06:54 PM
here is a test i did using your scene, i just deleted the env sphere and created an IBL sphere, not visible in reflections/reflations just visible to the FG rays
http://img37.exs.cx/img37/8458/teste.th.jpg (http://img37.exs.cx/my.php?loc=img37&image=teste.jpg)

and with alpha channel:)

kylee
08-30-2004, 07:27 AM
hi.

I had the same problem with you.

And my friend told me a trick to solve it.

Just change Far Clip Plane value of camera closer than the distance of Env Sphere from

camera.

^^;;;

CGTalk Moderation
01-19-2006, 02:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.