PDA

View Full Version : Removing expression for bones


ASW
08-01-2004, 10:01 PM
I set up a link with orientation to create bicep bulges and they didnt work so now I want o go with the more controllable link with command, but first I need to remove the expression form the orientation of of my bones. I've deleted the shapes and shape tracks but for some reason I cant get rid of thge expressions. I tried remove animatin expression but I'm having no luck. Thanks alot in advance

http://www.vfs.com/%7Eangusw/unmark.jpg

SheepFactory
08-01-2004, 10:10 PM
right click and remove animation

ThE_JacO
08-01-2004, 11:39 PM
that plug icon means that the parameter is controlled by a clip in the mixer (expressions are a C if it's a constant, an equal if it's a simple equality expression or an arrow for anything else).
you could remove all the expressions in the world but that still exists as a clip in the mixer ;)

delete the clip from its track and you'll be fine.

ASW
08-02-2004, 12:32 AM
Strangely enough I've already deleted the clip from the mixer. So I have no idea why it would be hanging around. hmmmmmmm

ThE_JacO
08-02-2004, 12:41 AM
check in other mixers, a mixer lives in a model space or in the scene space, but if you re-connected you could have a zombie clip in a mixer where you wouldn't expect it to be.

is that rig in a model? is it in scene space? are you sure you aren't maybe checking in a model storing geometry while you have the rig in a different model? are you using ref models?

over the past year of pipeline engineering I've exploited the mixer, expressions and SCOPs so much I can't be arsed even thinking about it, but I've never seen a parameter sporting a wrong icon neither any ghost clip phenomens.
the multiple mixer system and cross connections can be dodgy if you don't know exactly what's going on and have no scripts to check things for you, but it's not buggy in those regards.

ASW
08-02-2004, 02:45 AM
The rig is in a model node under the scene node with no other models in the scene, I first deleted all the shape sources then I deleted all the shape tracks in the model as there were none in the scene. And its still there. I'm just going try setting another link with on top of it and see what happen. Maybe it there because I deleted the source clips first then the tracks. I could go back a scene version before I deleted the shapes and delete them in the order you suggested. I'll see if that works.

CGTalk Moderation
01-18-2006, 08:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.