PDA

View Full Version : importing .obj files & using displacement issues


BurningSensation
07-28-2004, 03:34 AM
i'm experiencing some strange things when i try to import .obj files from zbrush. i'm trying to export the files with uv coordinates and textures (though the texture is just grey for now). firstly, when i go into shaded mode in the viewport, the object appears completely black, with no actual shading. (with and w/out headlight on) when i go to render, it is a flat shaded gray with lots of black artifacts. the .obj file is coming from zbrush. i've modeled the object (an elephant) in xsi and am trying to export it to zbrush as an .obj file (success) deform it and possibly texture and import it back into xsi. i tried unwrapping my own uv's and importing them to zbrush, but i get all kinds of strange results for the dislpacement map. so i thought i'd use zbrush's own automatic seamless unwrapping tools to give better results. in zbrush it appears to be working, but when i import it into xsi, i get the above mentioned results. removing the exported texture map (an all grey one) does nothing to improve the situation. Nothing seems to be working, even with the exact settings of several demonstrations i've seen, my renders look terrible and take forever, often hanging my machine. i'm really lost as to what to do. any help is appreciated


ps. the specs on my machine are 2800+ athlon XP and 512 mb of ram (soon to become 1gb)
pps.
i just tried out the nice looking head scene that's posted over at xsibase and (woohoo) it works. i had to flip the displacement map and it still took a pretty long time to render a small render region. i'll do a render at like 800x600 and post the time it took here in a reply.

BurningSensation
07-28-2004, 03:49 AM
ok it rendered real fast that time. i'm not sure why it took a long time in the render region. perhaps it was busy generating a the displacement map after i'd flipped it or something.

ndog
07-28-2004, 04:05 AM
If you apply a displacement map in XSI and then export the model as an .obj will the mesh contain the displacement map detail?

I need to generate a hi-resolution displacement in ZBrush but pose the model in XSI and then export the deformed, posed model as an .obj for RP use.

BurningSensation
08-05-2004, 06:12 AM
no, but rest assured there is a way to do that. i just don't know it. :) i'm new to softimage

CGTalk Moderation
01-18-2006, 08:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.