PDA

View Full Version : E-mail notifucation not working!


Apollux
06-29-2004, 04:29 AM
since about a month before CGTalk was upgraded, the notification service stoped working for me. Tryed both instant notification and daily notification.. no use.

I double checked that the e-mail address is correct.

By the way, when you are subscribed to a forum, aren't you supposed to receive notifications when someone post a new thread? Because that one never worked for me neither.

Kirt
06-29-2004, 05:59 PM
We can't do much about what was happening with the previous version of the board. However, I haven't had any problems with subscibing to threads. I get e-mail notifications just fine.

You do have to make sure that the drop down box is selected for "Instant notifications by email" because there is a "No email notifications" option that it may be defaulting on. Aside from that, I can only suggest double checking the email for typos.

I'm trying the forum subscribe now ... I'll let you know if it's working for me tomorrow (it notifies once a day or once a week only).

Hmmm ... that's a lot of typing to say, "I don't know other than what you've tried already." Sorry. :argh:

Apollux
06-29-2004, 09:24 PM
Double checked my settings (again)... the subscribed thread does show up when I enter the Control Panel, but e-mail notifications are never received. :banghead:

Kirt
06-29-2004, 10:57 PM
In your user control panel under subscriptions, does each thread say "Instant" on the far right?

Apollux
06-30-2004, 03:26 AM
Kirt, you are gold !!!

I haven' t noticed that section at all! Just took a look and some threads say daily, others say instant, but none of them have it' s checkbox market!

I think that it would be wiser if those checkboxed get automatically market when you click on the "Suscribe to this thread" button, but apparantly it doesn't.

I just checked a few of the boxes, let' s see how it turns out now.

Edit:

Ok, I checked the boxes, but how do I save the selection? Clicking on GO just re-loads the page, and all threads show again unselected :(

Apollux
06-30-2004, 04:11 AM
Just realised that the checkboxes are only for deleting or movind the threads around :sad:


I has come to believe that it is some sort of database corruption going on. For example, I have "Receive Email from Other Members" activated, but when I try to send myself an e-mail trough CGTalk, this is what I get:

"Sorry! That user has specified that they do not wish to receive emails. If you still wish to send an email to this user, please contact the administrator (do_not_reply@cgtalk.com) and they may be able to help." :shrug:

Who is the person in charge of data-integrity issues around here?

Kirt
06-30-2004, 04:54 AM
All subscription services are working fine for me. From the latest info you've provided I'm guessing it has something to do with the e-mail notification option that is disabled in your profile. I tried to email you through the board and I got the same error.

There should be a check mark in both of the email options 1) Recieve email from Administrators & 2) Recieve email from other members.

Also, double check your email address that it doesn't have a spam guard blocking any addresses from @cgtalk.com Notifications will come from "CGTalk Mailer" <do_not_reply@cgtalk.com>

I'll point someone to this thread who's in charge of the servers and database. Hopefully we can get it fixed for you soon, but there's quite a few people out on vacations right now. Sorry. :sad:

leigh
07-01-2004, 01:20 AM
It's odd, for about a while during April and May my own email notifications weren't working either. And then one day they just started again :shrug:

It might be your mail server bouncing them as spam though. I suspect this was the cause of mine.

Apollux
07-02-2004, 10:09 PM
Doubfully, since I'm still getting the monthly news letter :cry:

Apollux
07-06-2004, 04:23 PM
Seems like other people are having problems with the e-mail system also :banghead:

Mibus
07-07-2004, 03:28 AM
Hi guys,

I've looked into this as best I can, and from what I can tell the emails are getting generated properly, and being forwarded to the correct mail server, which is accepting the email. It is clear that emails don't get through, so my guess is it's a simple mail-spam-filter that is incorrectly identifying CGTalk emails as spam.

I signed up with a hotmail account, and although I got the initial registration emails, I didn't get notifications (even though they were sent to the hotmail mx server).

After much further investigation, it seems that some domains just don't accept any emails that are sent via the database (if multiple emails are to be sent, CGTalk will just make a list in the database and send them later, if it's just one email it'll send it there and then. Note that by "later" i mean "over the next few seconds" - VB splits emails into groups of five and sends them that way, so you don't have excessive page-loading times when you've just posted, as it emails 100 people subscriptions.).

I really don't see why it's not working, so I'm gonna leave Leo a note for when he gets back (from his well-deserved vacation).

Garma
07-08-2004, 11:03 AM
Note that by "later" i mean "over the next few seconds" - VB splits emails into groups of five and sends them that way, so you don't have excessive page-loading times when you've just posted, as it emails 100 people subscriptions.).

that would mean PHP puts the addresses in the bcc line, making them invisible to the receiver. This is almost the same as labeling it with "spam" from a filter's point of view. Putting it in the save-senders list should work. It would not surprise me if Hotmail rejects them before they even reach your account tho.

the newsletter is from cg networks and afaik sent from a different address..

Strange thing regarding spam: I run Outlook with spam setting default. It filters out every piece of spam (about 10-15 a day), only 2 got through in the 5 months I'm using it now. CGTalk and CGNetwork mails go through tho, I have no idea what the criteria is for those to pass..

Mibus
07-09-2004, 01:24 AM
that would mean PHP puts the addresses in the bcc line, making them invisible to the receiver. This is almost the same as labeling it with "spam" from a filter's point of view. Putting it in the save-senders list should work. It would not surprise me if Hotmail rejects them before they even reach your account tho. No... It still sends individual emails "to" that person. What happens is this:

- Person replies to a thread
- Since sending the subscription notifications would take a while (it might have to send 100+ emails), it just creates a row in a database table "person $FOO should be sent an email with subject $SUBJECT and body $BODY".
- Page returns, displays "Submitted post" or whatever.

Now comes the weird part:
- VB has a registered "shutdown" function, which is called after the page has finished all other PHP and HTML executing/rendering. This shutdown function pulls five emails out of the "email these people" mail queue table in the database, and sends them an email each.
Thus, the load of sending those 100+ emails is spread across 20 page views.

If I manually enter an email into that table, and have it go to an email address that I get subscription notifications to, it works. (It can be any random email content, its a very generic system). If I put an email to my hotmail account into the queue in the DB, it just disappears. Checking the SMTP logs on the server shows that it accepted the email from PHP, and passed it on to hotmail.

Somewhere it's getting lost... I just don't know where. I'm guessing at this point that there is a slightly different header configuration between batch emails and at-once emails (like for signing up, where they're sent in the body of the page instead of being added to the DB).

the newsletter is from cg networks and afaik sent from a different address..
Yup, the newsletter is run on one of our servers (the one for cgcommunity), using a DB list from the server that runs CGNetworks.com itself.

Apollux
07-13-2004, 12:32 AM
Just wanted to add that in my case, I believe to have total control over what e-mails get passed to me and wath is not. I'm using a commercial e-mail server and have all the spam filtering options off.

All the spam filtering is actually performed on my client applications (Outlook and Evolution), so ... I'm still clueless about what is going on.

Shall I repeat that the problem presented itself way BEFORE the forums update :sad:


When is Leo returning from vacations anyways?

Mibus
07-13-2004, 12:57 AM
Weird.

He just got back, but he's still got stuff from his break to sort through. I talked with him about it this morning, he can't think of any reason for you not to get the emails either...

We're looking into it, but I'm afraid you're just gonna have to wait :-/

Mibus
07-13-2004, 12:58 AM
Weird.

He just got back, but he's still got stuff from his break to sort through. I talked with him about it this morning, he can't think of any reason for you not to get the emails either...

We're looking into it, but I'm afraid you're just gonna have to wait until we can find a solution... :-/

A newer version of the bulletin software mentions 'email-related fixes', but doesn't explain what they are... hopefully when we upgrade (no timeline yet) it'll fix it for us!

Mibus
07-14-2004, 03:25 AM
Upgraded to VB 3.0.3 - has it helped any?

If not, try creating a new account - does it send you the inital email (with the activation link)?

Apollux
07-18-2004, 12:29 AM
No difference so far, will try with the new account (although I' ll loose my post count :sad:)

If the new account works ok, do I get to keep my old nickname with it?

Mibus
07-19-2004, 04:45 AM
No no, I don't mean for you to have to use the new account... I just want to know if you'll get the initial email that is sent! :)

I want to know if it's just affecting the bulk mail (in which case I can look in that direction) or if it's affecting all mail (in which case I'll look at the SMTP engine itself).

Don't panic! ;)

CGTalk Moderation
01-18-2006, 02:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.