PDA

View Full Version : need help: multi-texture rendering issue


Onieros
03-20-2004, 05:45 AM
Hi guys,

I'm working on a forest game environment and I'm having some issues with a multi-texture on my ground when i render. I have my multi-texture set up as so: A layered texture with the first being a targa image of the paths and rock areas overlayed onto a repeating grass texture (tiff) which is multiplied over the color information texture (tiff) then I have 2 UV sets on the ground object the 1 UV set linked to the targa image and the color info texture the 2nd UV set linked to the repeating grass texture. It shows up fine in the Hardware view but when I try to render it out the transparent parts of the targa image show up white in the render blocking out everything underneath. I've asked a bunch of my instructors and they didn't know what was going on. If you guys know any way around this or how to fix it I could greatly use the help. I was originally attempting to use the Hardware Render Buffer but I'm having Alpha sorting issues.

Any help on this would be greatly appreciated. I'll attach a screengrab and then a render shot so you guys can see what I mean

Thanks

Onieros
03-20-2004, 05:46 AM
Here's what the render of the same shot looks like.

Timefly
03-20-2004, 07:42 PM
this is just a fast idea, would have to think more..or possible troubleshoot the scene itself if it doesnt work...but try to pull your filenodes default color (under color balance) to all black

T

Onieros
03-21-2004, 10:44 AM
Thanks for the response timefly. :) I checked the default color and it's black... It'll automatically default to black when you map a file texture to the color channel... :shrug: I'll just have to go with the hardware render buffer and give everyone that watches my reel a siezure from the flickering alpha maps... maya's got some icky hardware alpha sorting... :p ;) ...

thanks again

CGTalk Moderation
01-17-2006, 08:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.