PDA

View Full Version : maya + messiah = mangled mesh


womanonfire
03-16-2004, 03:59 PM
i am using the messiah->maya connection (demo)
when i select my character (which is made up of several pieces) and type messiah -ad to get it into messiah program my mesh is completely destroyed! truely mangled beyond all recognition! and the transfer fails. if i then try to load the model again, Maya crashes. On startup i have to make sure that the plug-in is not loaded or it will crash again when i try to open a scene.

am i doing something very very wrong or , um, is this a "bug" :surprised ?

i seem to remember someone else on the forums having the same problem... but i don't recall if it was solved.

gsuttor
03-19-2004, 03:28 AM
Try deleting all history in Maya before you send it to messiah.

Select your mesh and...

EDIT -> Delete by type -> History (in maya)

then select it again and type...

messiah -ad (in the maya help line)

Should do the trick hopefully, fingers crossed.

womanonfire
03-19-2004, 10:09 AM
that does not help :cry:

gsuttor
03-19-2004, 08:54 PM
Oh wait, I skim read. You have several pieces, are they all group under a single node or seperate in the outliner?
I seem to vaguley recall an issue when trying to multi select and send objects to messiah at once.

Try ungrouping them if grouped, and select one at a time and messiah -ad them one at a time.

I'd try myself if I was at work.

I've got models in many times, maybe it's because they are usually 1 mesh to them.

gsuttor
03-20-2004, 11:22 PM
Yep. I can confirm that bug (using the animateDemo - I didnt use studio for the test)

If you multi select objects in Maya and 'messiah -ad' them all at once your objects in MAYA with get trashed, that is, the second and consectutive objects. The first object will be fine (and is the only one that ends up being sent into messiah).

If you do this multi add, you can fix each object by deleting the messiah defrom attribute in the attribute editor of each object and re adding them one by one.

So... it seems each object MUST be 'messiah -ad' seperately.

womanonfire
03-25-2004, 08:39 AM
thanks gsuttor!
i just got around to trying it again. yes that does work. my character was all grouped together, i ungrouped and sent the pieces separately, and it is fine. i just did not think to do that, and i am sure other people who would try to send a multipart character will think the messiah->maya connection is broken too! there should probably be a note abot this somewhere in the documentation (or they should fix it :rolleyes: ) but anyway... now i can get on to learning how to use this app better.

CGTalk Moderation
01-17-2006, 05:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.