PDA

View Full Version : error Blender on IRIX


RokieTheJawa
03-16-2004, 12:37 AM
Hi!

I need some help with Blender. I got the next error:

1777:blender: rld: Fatal Error: Cannot Successfully map soname 'libCio.so.1' under any of the filenames /usr/lib32/libCio.so.1:/usr/lib32/internal/libCio.so.1:/lib32/libCio.so.1:/opt/lib32/libCio.so.1:/usr/lib32/libCio.so.1.1:/usr/lib32/internal/libCio.so.1.1:/lib32/libCio.so.1.1:/opt/lib32/libCio.so.1.1:

when I want to run blender on Irix 6.5

First I had a problem because I tried to run it as root, but nothing happened, so I created a super-user acount and logged in as the new account and then used the "./blender" command to start blender on my blender directory, this created a new directory ./blender on the same directory, but nothing happened, only the last error I showed you.

Do I need a new version of Irix? because I tried to find the version but the system only shows IRIX64 Version 6.5

I remember that once I saw something like 6.5.0.12 or anything like this, but I also remember another newer version that the last one a saw first, 6.5.0.25 or something like that.

Do I need to install a new Irix? is this a common error of Blender? or do I need to install something else? o is only a missing file?

Thanks!

actionfigure
03-16-2004, 10:55 PM
This library, libCio.so, is part of the SGI c++_eoe package (C++ execution only environment). See http://freeware.sgi.com/faq.html#Q2.2 for some details and instructions. The patch is free.

Here are some other site that MAY help.


http://www.blender.org/pipermail/bf-committers/2003-May/002727.html

http://www.sgi.unizh.ch/docu/relnotes/faq.html


:hmm: Some help is better than no help

RokieTheJawa
03-17-2004, 12:04 AM
Thank you!

I solved the problem downloading the file from some page that I don't remmeber.

And thanks for the links, I'v found them looking on google as I've read on another post.

The blender still has some errors showed at the Unix Console, but it runs well, a friend from NicoDigital (Mataii) made a simple example using bones, he used the 2.32 for the bones and then returned to the 2.25 version and made an executable file, was great, it only runs at IRIX, we tried to see if work for Linux, but no.

And not all the games work well, the SGI that we're using for testing still has some problems.

I'm excited at this moment, I think this program is great and work better for interactivity than the old VRML. We've crossed through many problems because the IRIX is almost obsolet, I haven't seen as many aplications for Windows, Mac or Linux dedicated for 3D visualization.

Well, thanks!

RokieTheJawa.

Apollux
03-20-2004, 08:11 PM
Originally posted by RokieTheJawa
he used the 2.32 for the bones and then returned to the 2.25 version and made an executable file, was great, it only runs at IRIX, we tried to see if work for Linux, but no.
RokieTheJawa.

For a linux run-time you need to make it from a Linux Blender, same goes for a Windows run-time: you'll need a windows Blender.

Of course they all are made from the same .blend file, that's the beauty of it :buttrock:

RokieTheJawa
05-04-2004, 08:10 PM
Ok, the last one was an error related with only a file. It worked, some .blend on the SGI Octane that we use at the office, ran a little slow, and some other the slowest thing than you can imagine (.9 fps), but ir worked and was running well for modeling and that kind of stuff. OK, This time, with the new version (Blender 2.33) displays the next error:



1189:blender: rld: Fatal Error: attempted access to unresolvable symbol in blender: _xpg5_vsnprintf

Does anybody has the same error?

Thanks!

CGTalk Moderation
01-17-2006, 05:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.