PDA

View Full Version : rigged character wonīt "walk" on motion trial properly


PsychoSilence
03-03-2004, 07:45 PM
hy all ! my problem is this: i want to have my char, a bot, move along a motion trial. no prob so far...but if i attach the char and rig to the motion path the two things (poly char & rig/charset) wont "walk along" the same way :(

the rig takes a wider angle then the char so everything gets wrong...so what did I wrong ? in the help i couldnīt find anything about rigs&chars togather on one motion trial :cry: i grouped the poly char, the rig and the charsets and attached them to the trial.

please help me out, want my char animated AND moving please :cry: :cry: :cry:

thanks in advance

psycho

PS: hereīs a silly ani-test: http://www.core2core.de/f2c/ani_test.swf

and hereīs what happens, when i group it and attach it to the motion trial: http://www.core2core.de/f2c/emotional_agent_ani.avi

john_homer
03-04-2004, 01:22 AM
don't attach the geometry AND the rig..
the rig moves the geometry... so if the rig is moving the geometry, and the path animation moves the geometry.. you get double deformations...

just attach the rig to the path, that will move the geometry (thats what its for after all)...
.j

PsychoSilence
03-04-2004, 06:32 AM
okay, thank you very much ! how about the parts of the bot i didnīt rig like itīs body ? will it follow after the rig without any problems ?

john_homer
03-07-2004, 11:52 PM
what ever you are gonna animate the body with (or a parent of) should be on the path.

you really need to step back and understand, exactly what you are doing, why you are doing it, and what is controlling/moving what in you scene..
.j

CGTalk Moderation
01-17-2006, 02:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.