PDA

View Full Version : Caustics effectís problem


Tornado7
02-24-2004, 04:22 PM
Hi all,

Exist a way to avoid that a object receives photons from caustics effect but still receives photons from gi effect (My problem is that I canít fade the energy / number of photons or move back the light because the overall scene should be too dark, but with the current energy/photons/light distance configuration some object saturates ?

Bye and thanks
:)

Emmortal1
02-24-2004, 04:29 PM
Unlink the light that is emitting the photons that you don't want to effect on the surface and turn on Photons Obey Light Linking in your render globals.

Emmortal

Jozvex
02-24-2004, 08:49 PM
Another way is to:

1. Select the object

2. Open the Attribute Editor to the transform node's page

3. Under the Mental Ray section untick the "Derive from Maya" box.

4. Change the "Caustics" dropdown setting to "Disabled" or "Cast Only".

;)

Tornado7
02-25-2004, 07:41 AM
Thanks guys, you are great :buttrock:

Tornado7
02-26-2004, 12:39 PM
Hi guys,

Iíve still a problemÖ.

Iíve tried both your solutions; Iíve linked my caustics-spotlight (this spotlight has the Emit Diffuse, Emit Specular uncheck) only to the glass borders and checked Photons obey light linking, and Iíve even disabled the caustics, using flags, for the boxís glasses and for the wall behind the box, but, as you can see in the figure:

http://xoomer.virgilio.it/francesco_puccini/wip/caustics.html

the glasses saturate (The main light is a pointLight in which Iíve placed Caustic Photons to 0). Any suggestions ? :hmm:

Bye and thanks

CGTalk Moderation
01-17-2006, 12:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.