PDA

View Full Version : Rendering shadows only


Neural Riptide
02-10-2004, 04:55 AM
Ok. If you have an object, with no background, and you save it as a 32 bit .png, the backdrop is transparent when you open it in Photoshop.

Is there a way to do the same with the objects shadow? so that the shadow is the only thing that shows up?

I'd like to be able to create an object with a shadow but have the rest be transparent so I can change backgrounds without having to re-render.

Any suggestions?

NOTE: I've tried the Render Buffer Export, but am not having any luck. It still ends up with a black background when I open the file, not a transparent one.:surprised

Ayreon
02-10-2004, 06:19 AM
In the surface properties of the objects that receive the shadows, under the advanced tab set the alpha channel to Shadow Density. The objects that receive the shadow will now only show up in the alpha channel as shadows.
Here's a little example file:
example (http://www.basbrouwers.nl/example.zip)
Just render it and you'll see that the ground object doesn't show up in the alpha, only the shadows it receives.

Hope this helps!


Ayreon

Neural Riptide
02-10-2004, 04:39 PM
Thank you very much! I spent quite a while playing with the "Render Buffer Export" add-on in the Image Process settings.

Very much appreciated. Thanks again. :thumbsup:

CGTalk Moderation
01-17-2006, 09:00 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.