PDA

View Full Version : ikSC Solver problem Need help


greynite1
12-12-2003, 09:11 AM
Hey there

I'm having an odd problem with my Maya 5.0 IK Handle tool. whenever I use an ikSCsolver on a simple 3 joint leg setup when I click the handle tool on the hip joint and then on the ankle joint the whole thing twists 90' so the bend in the knee is pointing in the negative X direction. Tried resetting my preferrences and playing with the options for IK handles and I can't seem to get this to work right. IKRP solver doesn't seem to have any problems what could be going on here I don't remember having this problem on other boxes. Could my maya just need a reinstall? Thanks for your help.

wizard06
12-12-2003, 05:57 PM
not sure what you mean by selecting hip and other stuff, but if your rig is bending in the wrong direction when you're grabbing the ik handle and moving it you could, re-ik but before you ik handle it, if you select the joint and rotate it right-click and hold on the joint it will pop up with an options to set preffered angle, set that return your joint to bind position and ik it. hopefully this works, if not you could be having a gimble lock problem which means you would need a pole vector constraint to help the ik position, you could most likely read about that in maya help. good luck

dwalden74
12-13-2003, 12:11 PM
This is a 5.0 bug. Itīs fixed in 5.01.

greynite1
12-14-2003, 04:53 AM
Hey Dave

Just curious so what exactly is the bug. The weird thing is that sometimes it happens and sometimes it doesn't. Now I start up my maya installation and it doesn't happen at all. I haven't changed anything really that I would think would alter that or make it odd or change it.

How can I get around it. Do i just have to make sure I make everything in absolutely the right planes?

dwalden74
12-14-2003, 10:40 AM
I havenīt seen this problem anymore in 5.01. Why donīt you just update? Itīs for free, and there were many other fixes too which makes it a rather smart decision.

If youīre really stubborn about working in 5.0, however, I noticed that this flipping only occured when the chain was built in certain planes. Another solution was simply to use the ikRPSolver instead. In fact, in some of my rigging scripts I ended up changing some of the ikHandle types to ikRPSolver, just because it was the only working solution for that version. Then 5.01 came out and everything was fixed (again)...

:beer:
David

greynite1
12-14-2003, 07:34 PM
hehehe cool yeah I'm workin on it I just have alot of machines I need to update at work. I got one of them updated and it seems to be working good. thanks very much for the help. Dave you got a very cool site and some neat character scripts thanks for all your help.

CGTalk Moderation
01-16-2006, 10:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.