PDA

View Full Version : Maya, XCode and .. Mac Mini


uiron
01-08-2013, 11:00 AM
Having a plugin which I'm now publishing for Windows and Linux, I'm researching my possible options of delivering Mac binaries as well. I really don't want to go the route of having someone else with a Mac compile that for me, as I want to have a station myself to do any required testing, bug investigations, etc, as well as keep up with the frequency of builds.

I really want to get away with a budget solution, could anyone from a mac-land give an advice here? There are a few areas that are blurry for me.. most confusing one is software versions, as while most generic developer nodes suggest having a most up-to-date mac to keep up with the requirements, Maya notes speak of 2.4 XCode, and that's kinda the only XCode I ever layed my hands on doing some experimental compiles on borrowed machine. Anyway, confusion with software versions is what mostly keeps me from consdering second hand hardware.

I'm leaning towards just buying latest generation of mac mini - anyone had some hands-on experience how Maya runs there? I'm not thinking of loading even semi-large scenes in there, just some really basic stuff, nothing more than a 10k skinned mesh with some 50-ish influences. How slow should I expect that to be? Slow-enough-to-be-frustrating or better?

zeroeffect
01-08-2013, 06:11 PM
The biggest problem with the latest generation of Mac Minis is that there is no option for discrete graphics (Nvidia or AMD). Intel HD 4000 is what you will end up with. It would be a very good build machine, but for testing, you may encounter some issues due to integrated graphics.

Another thing to consider is which versions of Maya you will be supporting. Older versions of Maya may not install or work correctly on Mountain Lion (OS X). I currently use Snow Leopard for Maya 2011-2013.

I cannot speak to the best version of XCode but be sure to match the gcc version with Maya's gcc version. The docs show build requirements for each version.

uiron
01-08-2013, 08:24 PM
hm, so big alert sign for Mountain Lion then.. Alright. I think getting 2011-2013.5 to work would be good enough for me. Might have to consider some second-hand machine with snow leopard instead though.

ristopuukko
01-09-2013, 06:25 AM
I think getting 2011-2013.5 to work would be good enough for me. Might have to consider some second-hand machine with snow leopard instead though.

If I remember correctly 2013.n does not work on Snow Leopard anymore so for that you have to figure out something else.

I've been using Mac Mini (mid 2009) with Snow Leopard and 2011 & 2012 with now problems whatsoever. Had semi - big projects and smallish dynamics stuff and so far so good.
The gfx card is nvidia 9400M and it works just fine, especially if your main concern is to use it as a development platform.

/risto

ps: 10 years ago one would only dream about the power of that particular mini....

uiron
01-09-2013, 07:48 AM
Sigh.. you're right, 10.7 is officially the minimum requirement for 2013.

So what are my other options trying to run it all on one machine? Any reliable virtualization options? I've tried running a couple of shady mac installations on windows but ran into too many issues. What else.. Dual boot?

ristopuukko
01-09-2013, 08:09 AM
Well on the other hand my new machine is iMac with Mountain Lion and from 2011 to 2013 everything works fine.

If you need to compile fot 10.5.x you can download that SDK from Apple's developer site and you're good to go.

I guess.

/risto

CGTalk Moderation
01-09-2013, 08:09 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.