PDA

View Full Version : Screamernet saving to... FLX?! O_o


NanoGator
12-07-2003, 09:32 AM
Hi All,

I'm playing with Screamernet. It's working, no problemo there. But I am having an unexpected occurance. The scene is set to save the sequence to .PNG, but instead it's saving to .FLX. I've double checked, I didn't accidently mess up something. (It's even in the scene file...)

I guess I'm just a little surprised. It's happening on the host machine, haven't even bothered trying on a second machine yet. Heh. Anybody know why Screamernet would do this?

NanoGator
12-07-2003, 09:42 AM
Grrrr okay I figured it out.

When you run LWSN.exe, you have to set a config file for it. Well, the tut I used said something like

lwsn.exe -cC:\command\lwg3.cfg

Unfortunately, that's a little too specific. I think Lightwave wasn't loading the other plugin that says "here's where the saver is." So I instead use this path:

lwsn.exe -cC:\command

The key difference was I removed 'lwg3.cfg'. Oh, and if you put a backslash on the end of it, LWSN.exe will crash. Lovely.

So yeah, if you ever use Screamernet, remember not to specify the config file, only the path to it.

kevman3d
12-07-2003, 09:45 AM
Is your configs and plugins all being loaded from the same place?

If I remember how this happened, it was something to do with not being set up properly to load the plugins/configs/both.

I posted a really basic Screamernet setup tute on NewTek's old forum system that works nicely. I would suggest comparing what you've done and see if there's anything different. Sorry couldn't help more then that...

http://forums.newtek.com/discus/messages/2/13419.html?

Kev.

kevman3d
12-07-2003, 09:47 AM
Doh! I see you fixed it between me reading your post and replying to it!

Nice work... Back to reading more postings! :)

NanoGator
12-07-2003, 09:55 AM
Heh thanks, I appreciate the help.

I have a question, is there a plugin that'll take all objects/textures/etc and move them all into another folder? Ideally it'd create a scene file pointing to the new folder, plus it'd take each of the objects and re-link their texture paths...

Anybody know of such a plug? That'd really help my screamernet experiences here...

kevman3d
12-07-2003, 10:15 AM
Yup - Its found under Layout, 'Scenes'->'Generic' and its called 'Content Manager'. This lets you export your current scene and all its assets to a new folder on disk. Very nice way to clean things up...

There are a couple of 'niggles' that make this tool a little annoying however...

One is that it doesn't see inside an object - So if you have textured an object using externally linked images on a CD, network, etc, then its likely you'll get the same issues when you load the scene later... You can fix these however with a little work in Surface Editor.

The other is that it hates objects that have 1 or more layers 'deleted' from the scene. For instance, a model where the first layer was a reference ground plane you added for rendering stills... So you just delete it from the scene...

Content manager will generate an 'Object Conversion Failure' if this is the case. Though its relatively easy to fix - All that has happened is that the scene has not been saved across, so you can manually do that yourself.

Once you've done that, just change your content directory, load the scene and for all the 'Cannot find...' errors, just select the appropriate images/objects from the new content directory... NEVER go searching for the originals from somewhere else on your machine or you'll end up with the same mess you started in!

Once the scene is back up, just save it again, and also save all objects to update everything. Now you have a nice clean content directory ready to dump onto the renderfarm...

kevman3d
12-07-2003, 10:23 AM
Also, don't forget to save any particle emitters out as .pfx files. And resave the scene.

Keep the pfx files inside the content folder.

Same goes for any "LScript" or "LScript/RT" plugins you've used. If you do a search inside your scene file with a text editor, check for any absolute file paths - ie. C:\mystuff\downloads\lscripts\

Absolute mapped paths ('externals') are a pain in the arse to be honest. I have a tool in beta that doesn't fix these YET, but it will clean up any narky plugins or other issues that might cause your scenes to crash LWSN ('Optimise' tab).

See if its any use (7.5c only unfortunately)

http://www.kevman3d.com/files/LCSM_10_BETA.zip

NanoGator
12-09-2003, 06:58 PM
Thanks for the info. :thumbsup:

Sorry I didn't respond sooner, I got my ass kicked by the common cold over the weekend.

CGTalk Moderation
01-16-2006, 09:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.