PDA

View Full Version : Area light shape graininess!


tkpolak
08-01-2012, 07:58 PM
Hi... so I have this problem with graininess when I use spherical lightshape:

http://img846.imageshack.us/img846/8070/wtfvcd.jpg

Does anyone have any idea what can I do to get rid of that? As you see I applied riddiculous amout of samples - for nothing. It is still as grainy as it was with regular 32.2.8.

I am rendering in mentalray with very expensive render settings so it should not happen :x

jeremyknoll
08-02-2012, 03:13 AM
are you sure its your area light? it looks like its mostly your candle wax that's grainy; maybe it has something to do with your shader?

tkpolak
08-02-2012, 09:09 AM
Yes I am sure it is the light. I checked how does it work on few different materials including blinn and lambert and it is grainy like that on each of them.

13xbmspec
08-03-2012, 07:51 PM
This really looks like a subsurface sampling issue. If you replace the light with a spot or point light does the noise persist?

tkpolak
08-03-2012, 08:04 PM
It does not. The problem occurs only when the area light with light shape is applied. I read about it but the only solution I can find is increasing area shape values.
It also happens when I use different shaders. Clearly AL issue. Stiupid Maya -.-

13xbmspec
08-03-2012, 08:13 PM
It does not. The problem occurs only when the area light with light shape is applied. I read about it but the only solution I can find is increasing area shape values.
It also happens when I use different shaders. Clearly AL issue. Stiupid Maya -.-

Well the values you have posted in that image are overkill.

See if any of this helps.
1. Try recreating the light source.
2. What does the shader network look like in the hypershade? Are plugging in the appropriate attributes/maps?
3. Any other lights in the scene that might be adding to the noise?

tkpolak
08-06-2012, 07:26 AM
Ad. 2 - yes everything is correct
Ad. 3 - nope


Ad. 1 - I noticed something, the amount of graininess depends of which light shape you use and so, rectangular shape leaves very few artifacts and it is easy to get rid of them. Circle shape generates a lot of noise and it is hard to deal with it, and finally spherical shape leaves insane amount of graininess and it is impossible to tweak it.

Retarded Maya -.- I needed few days to test everything that could influence the candle, read all the internets and thats about it. Maybe one of the 2012 hotfixes deals with it but... Meh I am seriously thinking of switching to Max. Rendering in Maya is such a pain..

Panupat
08-06-2012, 08:33 AM
How about the shadow rays under raytrace shadows? Would increasing that help?

tkpolak
08-06-2012, 08:58 AM
Raytrace tab was boosted up to a minimum value of 50 for each attribute and max of 200 (I wanted proper render really bad xd) so I guess it is not a problem. :shrug:

jeremyknoll
08-06-2012, 09:03 PM
You dont need crazy high values in your raytracing or arealight samples. like 13xbmspec said, its overkill. High values dont necessarily equate to better renders.

I attached a render using maya's misss-fastsimple and default sized sphere done in maya2012 sp2. The default misss values were grainy, just like your candle. I dropped the diffuse weight to .375, the front and back sss radius down to 2, the shininess 15, the lightmap samples 512, and scale conversion down to .5
I believe the miss shaders take into account object scale so if your candle isn't real-world size thats where the scale conversion helps out.

my arealights are only 1 intensity, the samples for the lightshape are 16,2,2 from top to bottom. my raytrace options are all default.

I know its still a touch grainy in the backscattering but its pretty close.

InfernalDarkness
08-08-2012, 08:46 PM
It sure looks a lot more like your shader's at fault than your light, and most of the values you're using are insanely high. Raytracing rarely needs 50 recursions - only if you were doing one of those infinite-mirror scenes or something equally silly.

What type of custom shader are you using for your area light, in the mental ray section of its shape node?

kanooshka
08-09-2012, 02:51 AM
It's very obviously the material. If it were the light, your entire scene would be grainy. I agree with Knoll3d. Check your conversion scale.

pap87
08-09-2012, 05:02 AM
Assuming you are using sss, how many lightmap samples are you using? Try cranking those up. Sss with large radii need more samples to get a smoother result. Default is 64 I think. Try up to 512, it doesn't affect render time as much as other sampling does.

If that persists, try even plugging in a physical light shader to the sphere light and see if the noise changes.

jeb
08-09-2012, 05:40 AM
beware that also when you have a visible area light it will create area specular and the graininess of that highlight depends on the samples of the light.

http://dl.dropbox.com/u/21996029/Image/Process/Visible-vs-NonVisible.jpg

tkpolak
08-09-2012, 11:18 AM
First of all I would like to kindly thank you all for all your help.
I still think mentioned candle material is not the problem though.

Here is what I have:

http://img29.imageshack.us/img29/1487/unopk.jpg


So.. what now? :)

As you may noticed spherical light gives me this great effect at the top of the candle which would be hard to achieve in different ways. That is why I am still testing it.

Knoll3d I used your material settings (though it is not misss_simple) and your conversion scale. Both my original settings (which were pretty much different as far as sss goes) and yours gave me exactly the same effect.

jeremyknoll
08-09-2012, 09:32 PM
thats weird with the blinn.

if you hide/remove everything but the arealight and candle I'm assuming its still grainy? What if you start a whole new scene; make just an area light and a cylinder. Still grainy?

without being able to poke around in the scene its hard to say where thats coming from.

tkpolak
08-09-2012, 10:03 PM
actally I deleted the spherical light and created entirely new one for its place with same parameters... now works fine.. this Maya..

jeremyknoll
08-09-2012, 10:22 PM
hah, yep. Probably some parameter buried deep in the area light. Glad its working for you now.

pap87
08-10-2012, 04:58 AM
Your original light was encompassing part of your geometry. Not sure if it is now, but I'll bet that was causing it.

tkpolak
08-11-2012, 10:21 AM
It was :) Thank you all for help again, I'm glad there is a place with ppl like you :cool:

CaptainObvious
08-22-2012, 10:16 AM
For future reference, the problem was basically that your light was encompassing the geometry. The way area lights work in almost all render engines, the standard inverse square falloff cause a lot of problems when the light is too close to the surface. At the intersection point between an area light and a surface, it's basically impossible to get clean results. It's often better to solve this kind of situation either by making damned sure that the light does not intersect, or by using two different lights and exclusion/inclusion flags, so you can have one smaller light illuminating the candle stick and one larger light illuminating the scene.

tkpolak
08-22-2012, 11:26 AM
Thank you Captain Obvious!

13xbmspec
08-22-2012, 05:04 PM
Thank you Captain Obvious!

At first I thought you were disrespecting him. Then I saw his user name. :D

CGTalk Moderation
08-22-2012, 05:04 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.