PDA

View Full Version : Krakatoa PRT Volume Animation?


Karanja
06-30-2012, 03:55 PM
I have a Mesh that is animated from down to up and then going forward, but when I creat a Krakatoa PRT Volume and add the Mesh with the Animation the Particles don't move.

Can they only be animated if the object stay on one point?

JohnnyRandom
06-30-2012, 08:16 PM
Which version are you using?

I ran into this a week or so ago. It is a bug in the current build, that is assuming you are using one of the latest builds. I reported it, they usually fix stuff like that by the next build, I hope :)

EDIT: Let me be a little more correct, there is a BUG with a keyframed base mesh. IE Standard Position, Rotation, Scale keys do not force the PRT Volume to evaluate therefore nothing moves. A animated deformed mesh with like one with a noise modifier on top will force the PRT Volume stack to evaluate.

3ak
07-01-2012, 05:29 PM
You can save particles from prt volume as prt file, load back with prt loader and use krakatoa SkinWrap modifier. it will be a bit slower but you get ability to deform particles with deforming mesh.
Or add magma mod to particles and pull out transform matrix from the object and apply it to particles. Will be faster but all you get is translation, rotation, scale of the object.

Bobo
07-01-2012, 07:46 PM
I checked and it is logged but not fixed internally yet. I will push for it next week.

Right now, you can do it like this:

*Create a Teapot, animate Position
*Create PRT Volume from it
*Check the "In World Space" option
*Add a Bend modifier to the Teapot, go to the last frame and SHIFT-Click the Angle spinner's arrow to set a key with value of 0 on the last frame. This creates a non-bending, but "animated" mesh.

At this point, the PRT Volume will correctly follow the animation.

When In World Space is off, you can simply link the PRT Volume to the source.

3ak
07-01-2012, 09:02 PM
I checked and it is logged but not fixed internally yet. I will push for it next week.

Right now, you can do it like this:

*Create a Teapot, animate Position
*Create PRT Volume from it
*Check the "In World Space" option
*Add a Bend modifier to the Teapot, go to the last frame and SHIFT-Click the Angle spinner's arrow to set a key with value of 0 on the last frame. This creates a non-bending, but "animated" mesh.

At this point, the PRT Volume will correctly follow the animation.

When In World Space is off, you can simply link the PRT Volume to the source.

Thanks for such a simple solution =)

mrkingers2011
06-17-2013, 02:32 AM
I have a Mesh that is animated from down to up and then going forward, but when I creat a Krakatoa PRT Volume and add the Mesh with the Animation the Particles don't move.

Can they only be animated if the object stay on one point?

yes,I met this problem 。
I found 2 methods,I hope it can help you.
my method 1:

covert the mesh animation to SD file (realflow),
then add KK PRT Volume to this SD mesh, that's all。

my method 2:
make (the mesh)point mode animation,Not object mode animation.
the kk PRT volume can follow the point animation.