PDA

View Full Version : Blender 2.6: How to undo 3D cursor movement


fridojet2
06-29-2012, 04:07 PM
hi, my mouse is very sensitive, and that's why I sometimes place the 3D cursor on the wrong location by a undesigned left click.

But when I'm trying to click Control + Z in order to undo the accidental 3D cursor movement, it doesn't revert.

So my question is: Is there an easy way to get Blender's (2.6) 3D cursor back to it's previous location? Thanks.

SNJ
07-05-2012, 02:58 PM
I'm going to give a provisional answer of, no. I will have to leave it to those more experienced with blender than I to give the definitive answer.

I can, however, give you a roundabout solution.

I had similar problems with the 3D cursor taking unscheduled trips to the top right hand corner of the 3D view port whenever I tried to split it and missed the handle, which was most of the time. I found the simplest solution, rather than improve my hand-eye coordination, was to set the 3D cursor control to double left click like so...

http://www.pasteall.org/pic/show.php?id=34365

The 3D cursor now moves only when intended but it's still convenient to do so.

oblio9
07-07-2012, 04:46 AM
That is flipping brilliant! Thanks SNJ!

dunawayc
08-14-2012, 07:34 PM
I found the simplest solution, rather than improve my hand-eye coordination, was to set the 3D cursor control to double left click like so...

Can you please describe the steps to accomplish this since, for some reason, I cannot see the image.

Thanks

ebasta
08-16-2012, 08:09 AM
Can you please describe the steps to accomplish this since, for some reason, I cannot see the image.

Thanks

Open the user Preferences in the File menu, go to Input tab and set the 3D View/3D Manipulator/Set 3D Cursor to double click.

Hope this helps.

thisroomthatikeep
08-16-2012, 08:39 AM
You can set the 3d cursor position from the Properties Panel (N).
Also, if you hit Shift+S you'll get a pop-up with the Snap menu with a few options to position the cursor.

dunawayc
08-16-2012, 08:16 PM
Open the user Preferences in the File menu, go to Input tab and set the 3D View/3D Manipulator/Set 3D Cursor to double click.

I do not have that as an option. I am running 2.63a (Windows) and when I go to the User Preferences on the Input Tab, I select 3d View -> 3D View (Global) and next to Set 3D Cursor, it just says "Action Mouse". If I click it, it says "Press a key". If I double click, it merely shows "Left Click". Is there some trick to get it to recognize a double click?

SNJ
08-17-2012, 10:12 PM
Expand 'Set 3D Cursor' and set the two drop downs on the right to 'Action' and 'Double Click'.

dunawayc
08-18-2012, 08:38 PM
Expand 'Set 3D Cursor' and set the two drop downs on the right to 'Action' and 'Double Click'.

Now I feel silly! It did not even occur to me that you could expand that another level!! But looking at it now, with the little triangle, it seems obvious. Doh!

:banghead:

hvanderwegen
08-19-2012, 06:00 AM
...or you install the Enhanced 3D Cursor extension, which allows you to set bookmarks, contains a cursor history, and drag and snap options. Better still, you can finally just drag the cursor, instead of clicking. Includes tangential guides for reference, and path visualization between prior locations of the cursor. Handy!

http://wiki.blender.org/index.php/Extensions:2.6/Py/Scripts/3D_interaction/Enhanced_3D_Cursor

thisroomthatikeep
08-19-2012, 09:33 AM
hvanderwegen, I did not know that add-on existed, thanks for pointing it out! :)

hvanderwegen
08-22-2012, 04:23 AM
Just make sure to deactivate this extension when you need full viewport performance for animation. It does affect fps when animating a character, I find. But it is great for modeling.

CGTalk Moderation
08-22-2012, 04:23 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.