PDA

View Full Version : PyQt Buttons not clicking


CadOp
06-10-2012, 05:43 AM
So im not sure if its really a Maya problem or just pyqt, im using qt designer and pyqt, for some reason I cant get some of the radio buttons and pushbuttons to actually have an action. I created all the elements the same, I tried sending any of the frames to the back, but it still doesnt work. Has anyone ran into this ?

Thanks,

Mat

zeroeffect
06-11-2012, 02:46 AM
I can't say I've had any of the problems you are experiencing with Maya and PyQt. Generally if a UI element isn't working it is an incorrectly defined SIGNAL or SLOT and the connection is failing. Are you making the connections directly in Designer or in the code afterwards? If it's in the code make sure your control names in Designer match the names in your code. Also, what version of Maya and PyQt are you using?

CadOp
06-11-2012, 04:29 AM
Hey zero, thanks for the reply. Im coding the signal and slot connections myself. It turned out the problem was with the heirarchy. I had a ui with a few tabs, when i first tried the ui, some tabs worked, and others didnt, so i looked in each tab trying to figure out what the variables where to get it working. Basically in my way of debugging, i would leave some elements out of their frame hierarchy and put some other in, thinking it would make half of them work. It turns out if just one element is not in the proper hierarchy inside a tab, then theres random results on which elements will work.

CGTalk Moderation
06-11-2012, 04:29 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.