PDA

View Full Version : Broken MAXScript or Documentation?


hellknows2008
05-22-2012, 12:41 PM
I am on 2012 but I also tried on 2011

It's about manipulating morph keys using MAXScript. You can read the doc here, http://docs.autodesk.com/3DSMAX/14/ENU/MAXScript%20Help%202012/files/GUID-EC94D744-7610-4814-83C7-AEF3719FD04-1417.htm. The example script doesn't work. It errors out at "setMKWeight k 1 100 true" and complains about "Runtime error: Morph controller key missing: #Barycentric Morph Controller key(1 @ 0f)". The same script that works in 9 doesn't work in newer versions, WTH?

Any help is appreciated. Thank you

Bobo
05-24-2012, 07:47 AM
I am getting 3 **system exception** errors in the same code in 2012 64 bit.
Also tried 2013 and got 4 system exceptions (from the last 4 lines).

I would suggest reporting it as a bug in Max, not in the documentation.

hellknows2008
05-24-2012, 01:37 PM
Bobo,

Thanks for confirming. I have just filed a bug report

CGTalk Moderation
05-24-2012, 01:37 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.