PDA

View Full Version : Subdivision Problem


TiSOy
11-24-2003, 08:37 AM
Im kinda new to lightwave, and I dont know whats the problem and maybe u can help me,,,,,,,When I subdevide a poligonial object and I tried to rotate it, for some reason it turns super slow. Can u pls tell me what may cause this problem? or What do I need to improve it......:p

Miyazaki
11-24-2003, 08:48 AM
LOL.
Naturally the refresh rate depends on your system specs and the complexity of your object. And make use of subpatching. Subpatch objects have a faster refresh rate than their polygonal froozen counterparts.

SplineGod
11-24-2003, 08:59 AM
Originally posted by TiSOy
Im kinda new to lightwave, and I dont know whats the problem and maybe u can help me,,,,,,,When I subdevide a poligonial object and I tried to rotate it, for some reason it turns super slow. Can u pls tell me what may cause this problem? or What do I need to improve it......:p
Hit the O key and lower the subpatch level. :)

TiSOy
11-25-2003, 02:09 AM
Thank u very much,,,,,I will try that........

vapulus
11-25-2003, 03:19 AM
Yeah, if you're trying to get a subdivided object, just select the polys and hit the tab key. I think that's more what you're looking for. That lets you change the mesh density on the fly in layout, too.

leigh
11-25-2003, 03:29 AM
When an object goes into Subd mode, it uses more memory since the model essentially becomes more complex (because of the subdivision level), so naturally it slows your computer down a little :)

rickycox
11-25-2003, 01:38 PM
Try to be ecconomical with Polys, keep the poly count down as low as possible.

TiSOy
11-26-2003, 04:32 AM
How can I make it faster? or atleast not super slow everything I move it angle to angle. Should I get a better Graphic Card or a faster computer? I use an old NVidia MMX 220 , 2500+ AMd XP, 512 memory......Is this okay? or what should I replace to get it better,,,,coz it drives me nuts rotating a subd in a slow mode....I tried to lower the poly count but the object is not as smooth. as I wanted it to be.........:buttrock:

SplineGod
11-26-2003, 04:37 AM
The higher the poly count of your base object the lower you subpatch level can be. Do you have a picture of your object?

rickycox
11-26-2003, 04:46 AM
I tried to lower the poly count but the object is not as smooth. as I wanted it to be.........

Just increase the 'Render' Subpatch Resolution in Layout (Object Properties Panel) when it comes time to render. It doesn't matter what it looks like in Modeler.

TiSOy
11-28-2003, 08:54 PM
It only slows when I do the subdivision in modeler, I would like to post it here but I scratch it and modeled it in maya instead, but Im not to happy with mayas modeler,,,,,Now Im trying to switch back to lightwaves modeler,,,,Maybe My poly count to high? I will post it here as soon as Im done with the rest of it,,,,,,:cry:

Brett H.
11-28-2003, 10:59 PM
Larry already nailed it for you: just lower your sub-d level in modeler. I run LW on an old farty computer at home and I do fine with even complex models. Just hit "o" and change the number where it says "Patch Divisions". I usually use 3, and change it as high as 6 when I want to see a really smooth version. In Layout, set your display sub-d to 1 or 0, and your render sub-d to about 6 (experiment).

Brett

milqman
11-28-2003, 11:02 PM
It seems upgrading your graphics card would definately help.

Anyone agree?

minus
11-29-2003, 12:10 AM
Does it happen if you were to say reboot your machine and open an object already subdivided in modeler? I ask as my laptop has some issues sometimes with slowdown going into full screen if say perhaps I was just watching a video tute or something. That may be a driver issue... or otherwise a video memory leak in my instance though.

But yea... model with low subdivision... and increase your render subdivision in layout. (select object... go to object properties... (button in the bottom of Layout)... and you will see the option there. 6 is kinda high.. you normally wouldn't go higher than that unless super close).

TiSOy
11-29-2003, 05:07 AM
Thanks for ur help,,,,,I will try lowering the subdevision lvl,,,,,and perhaps get a new video card......ahhhh another spending.....

Petrik
11-29-2003, 08:10 AM
It is the rendering subpatch level that you should be concerned about as far as smoothness goes. The other one is for your display as you're working. Now that one can come right down. It means it may look terrible while you are working on it but it will give you the speed you need as you're working and then it will look great once you've done the render because the other setting is on high.

I'm sure some one out can translate this criptic explaination for me.

This is actually another version of the explanations already provided.

TiSOy
11-30-2003, 05:42 AM
yeah I followed the instruction provided above when I render....and I followed the tips for modeling too,,,,it worked pretty good but still everytime I apply a subdivision so that i can see the result in real time in modeling, when I turn the object arround, it still do some clipping,,,,,,,,,maybe I need a new video card,,,,,I use mmx220 64meg........not sure if thats the problem,,,,,,or maybe I will just do my adjustment when Im about to render,,,,,,,,,,,:buttrock:

Brett H.
11-30-2003, 04:46 PM
How many polys are we talking about here? (In poly mode, hit "w" to see poly stats). I run an old 32mb card, and rarely have a problem at patch division 3. Making sure you've updated the drivers for the video card might help.

If you're still having problems, select the area you're working on, and hide the rest. This has helped me with full characters, just having, say, the head visible while I work on it.

Brett

Nemoid
11-30-2003, 05:30 PM
Your system configuration seem to be more than enough to turn a good poly model in modeler with no probs at all. so it may be some probs of the video card with Lw.

however, do a simple test with a subdivided poligon cube and then hit tab to toggle it in subpatch and see the results. also, be sure that a 3 subdivision level in modeler options panel, its enough for modelling ( the default is 6, but its a quite high subdivision) you can easily see the level of subdivisions when you turn flat shaded view in viewports.
be also sure to post here the polygon count of your model that you see in statistic panel
(hit w when in poligon selection tab to make it appear- faces is the required number)

the last suggestion of hiding part of your model can be very good, to work easily, especially if you have a full character, for example. it orbits faster and better.

TiSOy
11-30-2003, 08:38 PM
Thank u very much,,,,,,,now its working smoothly,,,,,,it only hapens the slow part when I convert it to subpatch and I selected mesh and maybe the value I put is to high,,,,,,but when I go to different route like u explained it seems to go smoother,,,,,,

CGTalk Moderation
01-16-2006, 07:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.