PDA

View Full Version : Digital Figure Sculpture GI Flickering


Stevejjd
05-04-2012, 12:50 AM
Hello,
Please help.

How do I stop Vray from Flickering?

Digital Figure Sculpture GI Flicker (http://vimeo.com/41530550)

I would be very regretful as I am getting my demo reel together.

Im am using Vray 2

*Image Sampler (Anialiasing)
Type = Adaptive QMC
Filter = Michell-Netravali

*Antialiasing filter
Min = 1, Max = 100
Clt thresh = 0.02

*Irradiance map
Present = Medium
HSph. subdivs = 25
Mode = Singleframe

*Light Cache
Subdivs 500
Mode = single frame

If Parameter not specified, then default value.

Material = FastSSS2

ndeboar
05-04-2012, 03:51 AM
what gi method are you using? Brute force is the most stable.

TheOnlyAaron
05-05-2012, 07:08 PM
It is hard to tell through the compression, but I have the sneaking suspicion that you have a sss shader on that statue as well? I have seen flicker come from sss that looks very similiar to what you have, not to say it couldnt be both.

ndeboar
05-06-2012, 11:29 PM
Irradiance map will always flicker unless you bake it out first, and then interpolate at render time.

Check this out for a guide:
http://www.spot3d.com/vray/help/150SP1/tutorials_anim2.htm

Also, you need to increase your pre-pass quality on the SSS, the default is quite low (i think it -1, try something like 1-2).

Stevejjd
05-07-2012, 02:32 AM
Thanks People - so helpful :D

dannyboy374
05-09-2012, 05:23 AM
Thanks People - so helpful :D

with Vray's SSS shaders, check the top of the shader attributes, what's the 'prepass' set at? if it's -1 or 0, try setting it to 1. Check your buffers in the VFB to isolate wether or not GI or SSS is causing this, or both.

For GI, if your objects are not going to be animated, bake out a Irradiance / light cache map. If this is a still frame, try brute force. depending on refraction values, you may have to turn on reflective/refractive caustics, this can also cause some sparkling.

Don't feel like you need to go to overkill values on your sampling, 1/100 is quite high. You may find identical results at around 2/25.

Also check your shaders reflection subdivision, the default 8 tends to cause noise if your glossy values dip below .95. Feel free to crank those up to 32, as they don't hurt render times too much.

One last thing, what's your light source? A vray dome light is a noise generator, if you're using one, I'd stick an HDR in there, or use vray rectangle lights for your setup. Just remember, DON'T SCALE vray lights, use the U/V size values in the attributes, scaling can cause unwanted noise.

vray is great, but there are dozens are places that can cause unwanted noise and sparkles. One last checkbox, in your render globals, under "Vray", down in the "color mapping" area, check "subpixel mapping", this will also eliminate yet another source of sparkling.

Stevejjd
05-09-2012, 09:24 AM
Thanks so much!

Im using Vray Plane lights

CGTalk Moderation
05-09-2012, 09:24 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.