PDA

View Full Version : Strange problem in Mental Ray - textures not appearing in reflections


Ubermatik
04-02-2012, 08:49 PM
Okay, so I swear this problem is bespoke to me, because I've searched everywhere and haven't found any mention, let alone a solution.

Basically, textures aren't appearing in reflections or refractions - bump or normal maps.

http://i.imgur.com/912sH.jpg

It's frustrating, because I've tried everything - is there a plugin I've accidentally disabled? Do I need to increase sample values anywhere? Or what?

You'll also notice in the screenshot a strange dark area beneath the glass - this is the first time it's happened, so it's not my primary concern, but I was wondering if there was a solution to this too? I've used the same preset shader before, no problems, so I think it may be my light setup. A common problem? Also, why does the glass make the rest of the scene brighter when looked through?

Thank-you in advance! Hope there's a quick solution for both these issues.

Ubermatik
04-02-2012, 09:12 PM
Just a quick notice: I only get the dark error with mia_material.

TheOnlyAaron
04-03-2012, 03:58 AM
Looks like you have more problems than just the refractions.

http://i.imgur.com/zpVHy.jpg

The shading is gone from there as well. I am assuming that is where some sort of raytraced shadow would go?

Ubermatik
04-03-2012, 10:04 AM
That's with caustics turned on and Photon emission from the area light I have to the left of the scene.
If it helps, I also have a HDRI image in the scene.

I'll try turning off photons/caustics to see if I can isolate the problem.

However, it's still the reflection/refraction problem that's the main concern. Any help here is greatly appreciated, because I really need to resolve this problem in order to continue!

LowJacK
04-04-2012, 03:56 AM
1. Turn up your raytrace settings. Render settings -> quality -> raytracing

2. Check the Ray Depth limit on any shadow casting lights.

3. Set your Final Gather Tracing settings to match that of your raytracing settings.

Ubermatik
04-04-2012, 01:52 PM
1. Turn up your raytrace settings. Render settings -> quality -> raytracing

2. Check the Ray Depth limit on any shadow casting lights.

3. Set your Final Gather Tracing settings to match that of your raytracing settings.

This has proved useful in reducing the intensity of the result, but I'm a little unsure as to what the values shoudl be.

Do you have any suggestions for values? Anything to ensure I completely eradicate the adverse effects in my image? Render times are not a concern for me, so as high as possible to ensure they don't appear again!

Thank-you!

kanooshka
04-04-2012, 11:47 PM
The trace depth values are different depending on the scene. For reflections 3 usually is good but it's worth testing more. As for refractions add 1 for each transparent face that is culled. For this scene you have 4 sides of the glass that are visible through each other. The shadow depth is for how many reflections/refractions shadows are visible through. You'll probably have to have this as high as your refraction depth. When in doubt either add 1 or reduce 1 to a trace depth value and see if there's any visible difference between renders.

-Dan

Ubermatik
04-05-2012, 02:03 PM
The trace depth values are different depending on the scene. For reflections 3 usually is good but it's worth testing more. As for refractions add 1 for each transparent face that is culled. For this scene you have 4 sides of the glass that are visible through each other. The shadow depth is for how many reflections/refractions shadows are visible through. You'll probably have to have this as high as your refraction depth. When in doubt either add 1 or reduce 1 to a trace depth value and see if there's any visible difference between renders.

-Dan


This has helped enormously, Dan, thank-you so much! It's cleared out my issue with dark refractions/shadows in the glass, which is excellent. Here's an image of my progress so far - yet the main problem still persists - no reflection/refraction of textures - both normal and bump! I even toned down the cloth map to see if it had any difference, but nope. Much in the way you can set depth limits and values for raytracing, is there something I need to increase in order to see textures through the glass? Is it, in fact, the same values I edited to get a better result with the lighting/shaders?

http://i.imgur.com/Ae6Mk.jpg

Thanks for all your help! I can see a solution to these problems slowly emerging.

InfernalDarkness
04-12-2012, 10:56 PM
I'm assuming this is Maya... What's your filtering like on that tablecloth texture? Default is Quadratic. Try Mipmap, with a filter strength of 2?

Is your Primary Renderer set to "Raytracing"? Default would be Scanline. Also, are you using BSP2 or Regular BSP?

There are five bounces through your glass to your texture. A good default ray depth would be 6/6/12, which you can then tone down later once it's all working.

EdtheHobbit
04-25-2012, 08:58 PM
I'm guessing that the texture on the tablecloth is a procedural.

Try turning off filtering entirely on the texture, and see if this fixes the problem. If it does, then start to dial in the filter settings until you get an acceptable result.

CGTalk Moderation
04-25-2012, 08:58 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.