PDA

View Full Version : Small Chunks in Fluids


Imatk
03-07-2012, 10:55 PM
So I've got a fire fluid sim that looks pretty cool, but I find that when the voxels start to spread apart or become thin, my fire has a sort of square, chunk look to it.

I've lightly circled an area with arrows on here to show what I'm seeing.

http://www.samjam.com/3D/Chunky.jpg

I've tried to up the resolution of the container and the quality of the shading is at 1.0 is there something else I need to do to combat this?

Thanks!

m0z
03-08-2012, 12:44 AM
did you set the render interpolation to "smooth" ?
seems to me like a voxel issue. I'd try with more voxels

cowboy71
03-08-2012, 01:07 AM
hey, looking nice man. With what I have encountered with fluid fire is that you don't need to go too high with the resolution, the fire quickly becomes too crisp for better words and looks unrealistic. As for those chunks you are seeing, this sim doesn't have any motion blur on it, and usually fire is burning pretty fast, so the motion blur is going to hide a lot. I get pretty good results with the solver set to "all Grids except velocity, and forward advection ticked on. Also play around with your Emission speed Attr. I usually use the "replace" method.

edit ( also just though about your opacity ramp) try and pull that down a bit. Hard to tell what might be the issue without seeing your settings.

Imatk
03-08-2012, 03:26 AM
did you set the render interpolation to "smooth" ?
seems to me like a voxel issue. I'd try with more voxels

No it was set to linear by default. I'll try that and also see about adding more voxels thanks!

Imatk
03-08-2012, 03:32 AM
hey, looking nice man. With what I have encountered with fluid fire is that you don't need to go too high with the resolution, the fire quickly becomes too crisp for better words and looks unrealistic. As for those chunks you are seeing, this sim doesn't have any motion blur on it, and usually fire is burning pretty fast, so the motion blur is going to hide a lot. I get pretty good results with the solver set to "all Grids except velocity, and forward advection ticked on. Also play around with your Emission speed Attr. I usually use the "replace" method.

edit ( also just though about your opacity ramp) try and pull that down a bit. Hard to tell what might be the issue without seeing your settings.

Thanks very much :)

I'll try it the motion blur and the other suggestions. The emission speed I had left at default, and the solver was also defaulted at "off"

Thanks for the help I'll report back and let you know how it goes!

Parv
03-08-2012, 08:48 AM
If (don't want to change the behavior of the sim)

mess with the opacity ramp and its input bias;

else
try a sim with high substeps;

It could be that a high swirl value is causing that. Also try lowering you temperature turbulence.

There are so many settings its hard to say what could be the cause..

CGTalk Moderation
03-08-2012, 08:48 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.