PDA

View Full Version : Bump not evenly covering mesh. Can someone explain it?


stormfrog
02-03-2012, 01:25 PM
I have a model on with a simple enough material applied.

http://dl.dropbox.com/u/3332901/couch_mat.jpg

When I render the bump is not correctly evenly spread over the mesh. I have used automatic UV-mapping (and tried everything else but manually mapping).

This is the result:
http://dl.dropbox.com/u/3332901/couch_bump.jpg

It doesnt look right at all. Some areas come out really well. Like the lower base of the couch thats indicated with the arrow. Other parts look just weird and there is moire interference patterns. I dont think its only the moire thats the bad guy. I think it looks like something else is amid; like the bump isnt spread evenly somehow?

I did a render with colors and set incandesence up with a ramp shader to mimic shadow of uneveness in the fabric:
http://dl.dropbox.com/u/3332901/couch.jpg

Its appearant from this render that the bump is much coarser at some places than others.


If I do a detail render the problem is even more appearant:
http://dl.dropbox.com/u/3332901/couch_detail.jpeg

The lower right part of mesh has the bump much more spread out. The other "sides" seems great from this angel. The top of the chushions however look just crazy ... but I cannot tell if this is messed up UV scaling or something else.



I would really appreciate some help and pointers on how to do this the right way. Since my material is so simple and consists of Maya drivern shaders (cloth) I dont really see how I could save a UV map and do the mapping manually in photoshop.

Why is the moire effect showing up? How do I make it go away in production renders?

stormfrog
02-04-2012, 02:13 PM
Ive now stitched the UV of one of the pieces of the model (a couch cushion). To see if that would solve the uneven spread.

My stitched UV:
http://dl.dropbox.com/u/3332901/couch_uv.jpg

Its not perfect but its only the front (lower part) that I care about anyway.

Render with bump looks like this now:
http://dl.dropbox.com/u/3332901/couch_cushion-bump-with-stitched-uv-uneven.jpg
http://dl.dropbox.com/u/3332901/couch_cushion-bump-with-stitched-uv-uneven2.jpg

So it seems to still be uneven even after Ive stitched the UV. All proportions seems correct when I render it with material only. But the bump map ontop doesnt come out anywere near as detailed.

Any suggestions what I am doing wrong here?

rip3rs
02-04-2012, 02:45 PM
Try decreasing your aliasing in the quality tab to 0.05 and min samples 0 max samples 3.

if that aint it, I believe the issue is in the UV-s

rip3rs
02-04-2012, 02:48 PM
Another thing is,

it could be that the UVs for that area (bottom right) are not stretching or skewing, while the rest are. or have a smaller area on the uvs where they should be larger, if you show us a image with a checkerboard repeated a lot of times (has though we can still see the checkerboard if it is squared still) we might see f it is UVs

rip3rs
02-04-2012, 06:26 PM
decrease the size of the top section in the UV space, whats happening is its a repeatable texture, so the bigger it is, the smaller the bump will look, or more of the texture will show in that area.

If you decrease the size of that face on the uv space you should start having similar "size" of bump like the rest.

stormfrog
02-04-2012, 10:29 PM
Thanks for the input rip3rs!

I messed around with the uv sizes to get fairly similar sized uv for all surfaces:
http://dl.dropbox.com/u/3332901/couch_checker.jpg


I then did a few test renders with:

V-ray:
http://dl.dropbox.com/u/3332901/couch_VRAY.jpg

V-ray with Vray Mtl instead of Maya Lambert and bump hooked up to the same maya cloth node:
http://dl.dropbox.com/u/3332901/couch_VRAY-material.jpg

Then I did a test render with MentalRay (FG/GI and ImageBased Lighting) and very different result:
http://dl.dropbox.com/u/3332901/couch_MR.jpg


The VRAY renders still look wrong quirky, not satisfied at all. I am looking for the famous "cloth":y feeling.

Something like this from Vray producers gallery:
http://www.chaosgroup.com/gallery/GFP_2_1323243978.jpg

tagorixxx
02-09-2012, 11:42 PM
You should check in your Bump Channel:
Edge Threshold and Center Treshold, play with those and im sure you gonna fix it.

CGTalk Moderation
02-09-2012, 11:42 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.