PDA

View Full Version : Texturing rendering in view port problems in blender 2.5


Aduah
01-15-2012, 08:04 PM
In a previous post on a different forum I was having some problems with getting transparencies to work correctly on a UV mapped strand for hair.

I actually figured out what my problem was on the transparencies.

Some 3d programs use a map and then a transparency map, but it seems blender lets you just use a transparent PNG. Nifty idea, but I think i'd rather use an alpha map in some cases. Is there a way to use texture & alpha to make a transparency in blender?

Also I'm no really sure if this should go here or in rendering... But here goes.

http://blenderartists.org/forum/attachment.php?attachmentid=167203&d=1326658838&thumb=1 (http://blenderartists.org/forum/attachment.php?attachmentid=167203&d=1326658838)

When viewing my texture in the view port at certain angles you see funky lines like in figure 1. Also, the transparency isn't really viewing correctly. In figure 2.) A you can see the tips, where the transparencies are supposed to be are just turning out grey. In figure 2.) B you also see along the edges there is some weird gray lines. Now, before anyone asks, I do have premultiply checked. In figure 2.) C I'm setting you up for figure 3. In figure 3.) A&B you can see that when the strand is selected, the transparency works just fine. In both A&B you can see through the trand like you are supposed to, where in figure 2.) C you cannot (As in comparison to figure 3.B )

Now, I read somewhere that if you should always have your shading set to GLSL that it would help with someone of these problems I am experiencing. However when I flip my shading from Multitexture to GLSL, it turns everything, including the model black, like in figure 4. Regardless of that, when I render, both in GLSL mode or Multitexture mode, my render turns out white, like in figure 5. I thought maybe it had something to do with my lighting, so I turned off the rending of all my lighting on the front, and the render is still completely blown out.

Kromar
01-19-2012, 09:26 PM
hi, getting transparency working in viewport is a bit a strange thing in blender, here is how you get it to work:

1. make sure you are in GLSL mode and have a light in the same layer (if no light is there your model will be all black)

2. in the material options enable transparency
http://i42.tinypic.com/2njepy.jpg

3. you asked for separate alpha texture so i will explain that version. add a 2nd texture to your amterial which will be used as alpha, disable Alpha use (no idea why this has to be disabled i will ask the devs tomorrow), and in the influence panel choose alpha.
http://i44.tinypic.com/2qs565e.jpg

4. voila viewport alpha should work at this point
http://i44.tinypic.com/aeb1o7.jpg


for your other problems, see if you still get grey outlines on the alphas with the methode above, if so try to anable/disable premultiply or Alpha: calculate

for the overblown light thing in GLSL there are 2 reasons i can think of why this happens, either your material settings are messed up or your light setup is way to bright. just move the light to a inactive layer and try with a new sun or hemi light and if that doesnt work try it with a new default material.

CGTalk Moderation
01-19-2012, 09:26 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.