PDA

View Full Version : Slight Vray bug


PandorasKeyboard
01-14-2012, 10:19 AM
Hi all, hope someone can help with this one.

http://vimeo.com/35051307

I've had a lot of flickering problems with my turntable rendering of this guy.
Thought it was looking well until I rendered the full thing and colour corrected a little before I noticed the little noisy bits appearing round the model.
This is the camera rotating around the model as I've been told reduces flickering with Irradiance maps.
Vray GI settings I think are the problem, and for this the settings are:

AO on,

Primary Bounce
Irradiance Map

Secondary, Off

Irr Map

Preset, Very High

Subdivs 50

Int samples 20

Int frames 8

Interpolation Type - Delone Triangle
Sample lookup - Density Based

Multipass on
Randomise samples on
5

Mode - single frame

To me this seems like overkill to a 1280 * 720 render
Going at around 8 minutes a frame.

The mesh is full of displaced tifs and normal maps straight out of Zbrush.

Any help appreciated.

PS feel free to critique the model itself :)

Cheers,

Jay.

asinn
01-15-2012, 07:47 AM
try to check this blog (http://www.mintviz.com/blog/flicker-free-animation-using-vray/) its max, but i think the principal is same..

hope helps

Azrail
01-15-2012, 08:27 AM
Since you intend to use IR map and only the camera is moving then you better bake the map, and then use it from file. The work flow is this:

GI bake pass - you set the primary engine like this:
irradiance map mode: incremental add to current map
auto save: On
then you render every Nth frame of the animation, in such way that every part of the model is visible in at least one frame, otherwise there will be missing samples in the ir. map which will look like something has burned there. You can turn "Render Settings->VRay->Global Options->Don't render final image" on just to speed the prepass. If you use light cache for secondary bounces set the mode to "Fly-trough" and auto save on again.

When it's done just set the ir.map mode to "from file" and render the whole thing.. and don't forget to turn "Don't render final image" off.
You can turn off the secondary bounces in the "render" pass, because they are supposed to be stored in the final irradiance map file.

Hope that helps.

EDIT: Or you can go to the Brute Force/Brute Force mode, with some playing around with the DMC sampler you can get clean and relatively fast results, but you should bump the samples up like 1/64 for the DMC sampler and 32 or more for the GI.. check this (http://www.interstation3d.com/tutorials/vray_dmc_sampler/demistyfing_dmc.html) post, it has a lot of info on the DMC sampler.

CGTalk Moderation
01-15-2012, 08:27 AM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.