PDA

View Full Version : Volume metric lighting with fluids as clouds


blueb2200
09-22-2011, 06:06 PM
Hello,

I'm creating a scene where I want to use fluids as clouds and use volume metric lighting to make up the god ray.

This is what I have done, successfully.
-Created volume metric lighting using the transmat shader group connected to the a cube
-connected the parti volume to volume shader in the custom shader section
-connected the transmat to the photo section in the custom shader section
-created a spot light
-connected MR "physical light" to the spot light

It all seems to be working fine except I con't get the rays to go through the fliuds and create the god rays. Also the clouds don't get rendered any more so I guess that's wear I'm stock.

How do I get the volume metric light to interact with the clouds (fluids) to cast the shadows (god ray) and how to get the clouds to render?

Here is my example of what i'm getting.

http://i397.photobucket.com/albums/pp52/blueb2200/testlight.jpg

InfernalDarkness
09-25-2011, 06:47 PM
Things may have changed since 2009, but in Maya 2009 introducing a fluid into a scene will break mental ray's Final Gather entirely. Fluids don't behave well with FG, or they didn't back then. I haven't tested with Maya 2009. If you have FG on, try rendering without it and see if that helps?

I'm assuming you have all your rendering flags set proper, "Cast Shadows", "Visible in Reflections/Refraction", "Receive Shadows", all that stuff?

But what may be at "fault" is that there are no polygons in the fluids. If you're able, try a different particle type (blobby, perhaps?) and see if that renders? Just some ideas.

blueb2200
09-25-2011, 11:00 PM
Thanks for the idea's I.D.

Ya, all of me flags are good to go. So I boiled it down to this when auto volume is checked off the fluids (clouds) render quite nicely. But when I have auto volume on then the clouds disappear. Question is why do fluids disappear when auto volume is on and how do get them to render and interact with auto volume?

It's good to see another Seattle boy on the site. I'm from Bothell originally, now in Ballard. You?

CGTalk Moderation
09-25-2011, 11:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.