PDA

View Full Version : Specular Problem in UDK!


ElmarNieser
09-19-2011, 03:02 PM
Heya,

I have this really annoying specular problem in UDK. Let me talk you trough it step by step with some images:

This is the model I created in 3dsmax, sinse I really need some high detail in this model's texture map. I figured unwrapping 1/9 of the model, and make it have overlapping UV's.
http://www.cgforge.org/01.png


This is the UV map for the model. As you can see the 'main ring' is just planar mapped, as well as the 'inner ring'. But for the rest of the model I used overlapping UV's to save UV space. I've read on the UDK documentation that this is no problem at all for the texture map, as long as the second lightmap has NO overlapping UV's.
http://www.cgforge.org/02.png


Now here is the model in UDK without specular. As you can see, everthing is working fine, no strange artifacts in the normalmap. It all looks like I want it.
http://www.cgforge.org/03.png


Now see what happons if a put a constant value of 1 in the specular slot of my shader.
http://www.cgforge.org/04.png


You can clearly see strange artifacts matching my texture unwrap. I really don't think there is something wrong with my normal map sinse it works great whithout specular (and it all works fine in 3ds max). Also my second UV set has no overlapping UV's and I doubt there problem is with the second UV channel because you can clearly see the artifacts matching the texture UV map.

What have I tried allready:

I tried mirroring parts of the texture UV map with no success. Checked all teh UV's for mirroring.

I checked my smoothing groups, there all setup correct. I debuged by giving the model just one smooting group, and I still got the strange artifacts matching my UV texture map.

I tried playing with the models settings in UDK. like 'Use Full Precission UV's', 'Use Maximum Streaming Texel Ratio', 'Light Map Resolution' etc.

I pretty much came to the conclusion that it is NOT possible to get my specular right using this texture UV layout. Changing the texture map to a working layout seriuously decreases my UV space making it allmost imposible to get this amount of detail in the model (unless I use a 4096 texture).

So the question is, is there a way to fix this? Or should i Change my texture UV layout to a much less effecient one having the model loose lot's of detail :( There must be a way to get this kind of detail in a model of this size!

Please help me out! This problem is starting to drive me crazy.

AlucardAssassin
09-20-2011, 02:30 AM
Could be a normals problem...try recalculating normals? Other than that idk how to help.

ElmarNieser
09-20-2011, 07:48 PM
Just updated the topic to describe the problem a bit more!

Bot13
09-21-2011, 07:53 AM
I think I know what's going on here. UDK tends to mess up the normals when you're placing them on top of eachother in the UV set. You should lay out every single face uniquely!

I know it's not ideal, but I know for quite certain this is what messes it up. :shrug:

edit: I just read your edit where you say you've already tried mirroring everything.. I suggest you lay out the complete inner ring again, just without any cuts whatsoever. Then when it's still mirrored for some strange reason, it will at least be mirrored completely and not per segment. Will probably also solve the problem.

archerx
10-08-2011, 06:26 PM
Yea the UDK doesn't like overlapping UVs

sprunghunt
10-09-2011, 07:04 PM
try this:

http://udn.epicgames.com/Three/ContentBlog.html#Fixing specular highlights when using X and Y symmetrical texture mirroring

CGTalk Moderation
10-09-2011, 07:04 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.