PDA

View Full Version : IK Issues?


Geneses
11-05-2003, 12:20 PM
I'm scaling a character, but the IK seems to be causing issues. For each key of each bone, the first thing I do is to set the IKBlend to 0.0 and the IKSpace to 0 (character-space).

After I do the scaling, I set the IKBlend and IKSpace values back to what they were originally. The problem is that when I set the IKSpace back in script, the bone seems to go back to it's pre-scaling world-space position.

Now... if, after I've set the IKBlend values back, I MANUALLY change the IKSpace values of each key, there is no problem. To debug this, I've tried sticking a specific key into a variable and looking at the values of all it's member variables. Then, after changing the IKSpace by hand (clicking on the 'Object' radio button, rather than the 'Body' one in the Motion/Key Info/IK section), the only value that has changed is the IKSpace. I figure that something else must be changing as if I only set this value in script I get these problems.

Can anyone help?

Gen

Wardile
11-24-2003, 09:18 AM
Hey, okay all that u said sounds complicated so im taking a gues its the samew prob i always have.

If i wanna scale my whole rig the ik's tend to give problems.

I found a solution for me,,, al i do is group it all, and i mean everything... then i scale it and no problems occur.

Hope it helps

CGTalk Moderation
01-16-2006, 03:00 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.