PDA

View Full Version : Low quality shadows through semi-transparent objects


Channel96
08-22-2011, 10:50 AM
Good morning!

I left a render of a semi-transparent plane over the weekend with high-sampling, shadow rays at 40, ray-depth limit 3, and raytracing options up to 10,10,20 in the globals and come back to find that the obkecys inside the plane still look ropey! It's definitely a problem that only effects objects we see through other objects..

Surely this has a simple solution? Unfortunately I've looked everywhere and have been unable to find it.

Channel96
08-22-2011, 05:38 PM
no-one knows about this artifacting? I'm surprised that no-one here has had this problem

nookie
08-22-2011, 06:23 PM
some images of shader/settings and render would surely help :rolleyes:

InfernalDarkness
08-22-2011, 07:03 PM
and come back to find that the obkecys inside the plane still look ropey!

Not sure what you're trying to say here... "...objects..." obviously, but what does "ropey" mean?

Post up a render or two; happy to help if I can.

UniqueCharacter
08-23-2011, 12:13 AM
While I am no rendering expert and am only in the rendering forum for help, you could try bumping up the depth limit to see if that helps, also check your render settings. Sorry if this sounds silly - just offering my help since not many did.

Bitter
08-23-2011, 03:21 AM
Area light in the scene?

Look at your low samples and low sample limit.

Channel96
08-23-2011, 11:56 AM
Thanks for all the suggestions so far! The shaders could be the problem since I'm using semi-transparent maya shaders with Mental Ray As for the Max Trace Depth I have this wacked up to 10 so don't think that's the problem but thanks for the suggestion. I'll do a test render shortly to find out I'm attaching some images to illustrate the problem and the settings I'm using...

The problem is difficult to show with a single frame but you can just about make it out. In a sequence these shadows in particular look very 'busy' -
http://i2.photobucket.com/albums/y12/Punksoulbrother/BadShadows.jpg

The shaders are standard Maya shaders, Lamberts mostly.. I wonder if mental ray shaders would be better? This is the transparent shader through which we see the dancing shadows
http://i2.photobucket.com/albums/y12/Punksoulbrother/TransparentMaterial.jpg

I racked up the quality settings in the globals and in each of the lights (3 directional, one spot) as you can see...
http://i2.photobucket.com/albums/y12/Punksoulbrother/Globals_Quality.jpg

The light raytracing settings are Light Angle-0, Shadow Rays-40, Ray Depth Limit-10

Any suggestions greatly appreciated. BTW - ropey = dodgy/bad.. maybe it's an English phrase?

Cheers!

Channel96
08-23-2011, 12:01 PM
some images of shader/settings and render would surely help :rolleyes:

By the way, love your showreel, you have an amazing command of passes!

nookie
08-23-2011, 12:28 PM
It's quite a lot that I don't use MR, so if I'm wrong don't kill me :P, but some settings don't really make too much sense to me, for example

shadow samples on light without radius it's overkill without any benefit, it should be used to raise the quality of blurred shadows.

AA at 1/3 could be useless, try to set it to 0/2 and lower the AA constrast first (like 0.05 or 0.03) and then, if you still have artifacts, raise it again

Using a mia material with mental ray usually helps. However, it looks like you are just using transparency without refractions, so no raytracing here (apart from shadows). You could lower you renderglobal raytrace settings to 2/2/4 (and even lower). Maybe try to increase the raytracing settings for shadows (they should be just below, sorry but no maya here eheh) on both renderglobal and lights

About your problem, you can play a little bit with the bias value in the lights and in the render global (if you still have one there). put REALLY little increments (like 0.001, then 0.002) cause it's really sensible. And try to work with a light at a time to isolate the problem easily :)

good luck!

ps: thanks mate :bowdown:

Channel96
08-23-2011, 01:00 PM
Thanks very much for your suggestions and you've introduced me to a few parameters that I hadn't paid attention to in the past! I'll certainly be looking into these, I guess I was hoping for an easy solution but it may well be a case of tweaking the figures till I sort them out..

InfernalDarkness
08-23-2011, 10:28 PM
Were you to switch to the mia_mat_x and lower your raytrace and light settings considerably, these issues would not only disappear, but render much, much faster.

Channel96
08-24-2011, 12:14 PM
Were you to switch to the mia_mat_x and lower your raytrace and light settings considerably, these issues would not only disappear, but render much, much faster.

This is certainly how I would have set the scene up, I didn't realise that the Maya shaders could be quite so unstable in Mental Ray though. Initial tests are looking promising, I'll get back to you guys when I get a sequence out!

Channel96
08-26-2011, 11:56 AM
I changed all of the materials to mia_mat_x_passes and this has not really solved the problem... still, my objects look a little nicer at least. I'm gonna try a new test in which I'm upping my Final Gather values, fingers crossed on this!

nookie
08-26-2011, 02:50 PM
did u try playing with the bias value?

Channel96
08-26-2011, 03:06 PM
I've managed to get rid of the flicker by upping the rays to 1000, freezing the final gather map, upping the filter a bit, and adjusting the min/max radius according to my scene scale... there you go

CGTalk Moderation
08-26-2011, 03:06 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.