PDA

View Full Version : Random bright pixels in Vray RT rendering with HDRI


Richard7666
08-22-2011, 06:21 AM
Anyone have any ideas how to get rid of this? Notice under the eaves of the house, the small bright pixels in the shadowed area. There are also a few random ones on the driveway.

Note non-RT rendering of the same scene is fine, no artifacts at all.

http://img810.imageshack.us/img810/3705/mavorasunset2.jpg

brucem91
08-22-2011, 07:10 AM
I am not familiar with vray, I use Mental Ray. However, I have had similar issues. Are you viewing this render in the maya render window? I've found for me that if I render to a 16 or 32 bit exr file and view in an external program like Nuke, AE, or PS, the dots go away. In mental ray I have frame buffer options in the quality tab so I can change to RGBA 32, perhaps vray has something similar.

ferzone
08-22-2011, 07:22 AM
Try to turn on "Subpixel mapping" in Color mapping section.

Richard7666
08-22-2011, 07:38 AM
Tried that, didn't help unfortunately.

I could just render in the full Vray render bit that takes a loooong time on this Core 2 Duo e8400.


@Bruce: well, I transferred to Maya's own framebuffer from Vray's and it made no difference. In fact the JPEG I posted is from Maya's.

thev
08-22-2011, 10:07 AM
If you are using the V-Ray sun light, you can try turning on the "Invisible" option; if you have reflective GI caustics enabled, you can try disabling them.

Best regards,
Vlado

Richard7666
08-22-2011, 10:22 AM
Reflective caustics is actually disabled in that render. Tested with it enabled too, no difference.
The sun light is also set to invisible already (I did it so only the hdri showed in window reflections) so it seems it can't be that either.

Thanks though Vlad :)

Airflow
08-22-2011, 11:09 AM
Again try sub-pixel mapping and tick clamp output.

Kyron
08-23-2011, 06:18 PM
I had that issue as well with the same setup as yours and the sun and sky system.
I can't remember exactly what I did to fix it, however in my case it had something to do with the reflection on my materials. If i turned it off the bright dots dissapeared.
The subpixel mapping only fixed it partially.

CGTalk Moderation
08-23-2011, 06:18 PM
This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.